Radiometric Terrain Flattering


#1

Hi there,
I just pre-processing Sentinel 1 data for an area in Canada. I did thermal noise removal, apply orbit file and calibration and now I am doing Radiometric terrain flattering with SRTM 1Sec HGT (Autodownload) . I could do it for some of data, but for the rest of this it gives an error like this:

A problem occurred during processing the target product processing.
**type: OperatorException **
Message: java.lang.ArrayIndexOutOfBandsException

Could you please help me through this?


#2

I have to also say that for Sentnel 1B IW ones also it says the DEM resolution is low! The best I can do based on the list is SRTM 1sec! What should I do then?


#3

Some other thing I need to add: I used Aster 1sec GDEM as well to check. The process goes and compeleted, but the final image is uniform dark gray!


#4

Hi @marifo,

Is your study area inside the coverage area of SRTM?


#5

Hi Yes I have its SRTM. but it is near the shoreline (near Hudson bay). do you think this can influence it. and what should i do?


#6

I would suggest to visually check the quality of your dem. Rigth click on the product -> add Elevation band. Your dark grey image could still contain valid pixel values, you can check in the Pixel info tab. cheers.


#7

In Processing Parameters, if you have the re-grid toggled on, can you try toggling it off?

That solved the problem for me a while back (although I cannot recall if my error message was the same as yours).


#8

Hi,

I am trying to perform RTF correction on ALOS-2 datasets. I first converted HH intensity value to beta naught then I performed RTF correction, but I am getting this error. Kindly guide me what’s the meaning of this error and how to solve it.

Kind Regards


#9

Is your DEM projected in WGS84?
May I ask where the 12m DEM comes from? You named it “dem_alos_12m_geo” which reminds me of the RTC products by ASF. In case that it is a side-product of ALOS PALSAR orthorectification it is probably only a resampled version of SRTM. The elevation information is not better.

I am telling you this because you could then just use the SRTM 1ArcSec DEM and avoid probable errors caused by the external DEM.


#10

Yes, I get it from RTC products by ASF and it’s projected to WGS84. Thank you for your correction, I also have TanDEM-X 12m DEM for my study area. I can use it. Right now I try to use SRTM 1sec (Auto Download) DEM and I unchecked “Re-grid Method”. It was executed successfully but the result is all zero pixels as shown in the figure below.


#11

is your area outside the SRTM region?

Source: https://www2.jpl.nasa.gov


#12

@ABraun my study area is north of Pakistan and it’s under SRTM coverage. I tried RTF correction using following DEMS.

  1. SRTM 1 sec (Auto Download)
  2. SRTM 1 sec (as External DEM)
  3. TanDEM-X 12m (as External DEM)

But I am getting the same error, the resultant image contains all zero values.


#13

does the Beta0 image look correct?
Which steps were applied until the Radiometric Terrain Flattening?


#14

Yes, Beta0 image looks correct as shown below. I just clipped original image to a small subset then convert to Beta0 and apply Radiometric Terrain Flattening.


#15

that is strange, should work actually.
Do you have the latest version of SNAP installed?


#16

Yes I am using SNAP 6.0


#17

Is there any particular prerequisite besides converting to beta naught in order to perform terrain flattening?


#18

No, this is the only requirement. You could maybe try the SRTM 3 Sec also


#19

Hi @ABraun I already tried with SRTM 3 sec but still getting the same result.


#20

I can’t think of an explanation for that, sorry.