S2 L2A product cannot be read

I am trying to open a Sentinel 2 image using python. But snappy cannot read the xml. I get the following error

Image processed:S2,20180404

Traceback (most recent call last):
File “F:\seo_dwarf\chl_scripts\Ocean_colour.py”, line 36, in
RuntimeError: java.io.IOException: No valid tiles associated to product [MTD_MSIL2A.xml]

Any ideas?

Do you have the latest SNAP version? See:

I have already updated the snap desktop (snap 6.0.0) i was using. Then i reinstalled the snappy in the python using https://senbox.atlassian.net/wiki/spaces/SNAP/pages/50855941/Configure+Python+to+use+the+SNAP-Python+snappy+interface.
But i get the same error. Is there any other way to update snappy?

After reinstalling SNAP you should open the desktop app and do
Help / Check for Updates.

Then you get the latest module updates.

When i open the same image using snap desktop i don t have any problems only snappy can not open it. Also i used sen2cor to correct it atmoshperically.

Probably you stumbled upon the same error as reported here:

In the last post of the thread, I describe a workaround.