S3 WFR values in exported GeoTiff different from DIM


#1

I exported S3 TSM (total suspended matter) and Chl to geotiff format using SNAP.
When I check the values in the geotif file using ArcGIS they are not the same as the values in SNAP Pixel Info.
To export I use a graph:
Read -> Resample -> subset -> reproject (WGS84)/geographic -> write as Beam-DIMMAP.
I then close SNAP, reopen, add them and use File -> Export -> geotiff.
I have tried a few variations in my graph like reading, subsetting, writing them directly to geotiff and other formats etc but no luck reading/importing them with ArcGIS.
Any suggestions greatly appreciated!!
Thanks
Brian


#2

Hi,
maybe it is due to resampling…Try to modify your resampling options by unabling the “preserve resolution” option and fixing the pixel resolution at 300m, similar to what discussed here:

good luck!


#3

Hi,
Thanks for the reply and your assistance.
Unabling the preserve resolution did not work.
The values of the resampled, subsetted, reprojected TSM_NN in SNAP DIM-BEAM format are correct and range from 0 to 100+ g/m3.
When I export as kmz all is correct.
However, when I export to geotiff the values range from 2 down to -1.35.

Regards
Brian


#4

This is related to the export to GeoTiff. When exporting to GeoTiff the scaling information is not considered. So you get the raw data in GeoTiff.
So you need to scale the value first to the geophysical representation: for TSM it is like this:
value = 10^(raw * scalingFactor + scalingOffset)
You can see the scaling values in the information dialog:
image

If you only want to export TSM, it should easily be possible to add the BandMaths operator to the graph.
You can do after the Resample operator. As expression just use the band name TSM_NN. In the new band, the scaling values are already applied and if you export this band you should have the correct values.


#5

Hi,
I wonder why in your info the description says:“Log10 scaled” but later on the “Is log 10 scaled” is set to FALSE.

The opposite happens for the products I have downloaded myself, which are not log-10 scaled in “Description” but the “Is log 10 scaled” is set to TRUE:


…rather a confusing thing…

However, from the S3 USer Handbook I see Dimension=g.m-3, so it seems the L2 products are not log-10 scaled, but represents the actual TSM values…


#6

My information dialog is taken from the tsm_nn.nc file, when I read it directly. It was just the window I had open at this moment. When I use the xfdumanifest.xml file I get the same table as you have shown.

In the netCDf file this is stored:

The information in the User Handbook probably refers to the unit after applying all scaling values.
And that’s what is shown in SNAP when using xfdumanifest.xml and read the full S3 product.


#7

Shouldn’t we get the same thing when opening a single file (*.nc file) or opening it through the xfdumanifest.xml file?!

How users should know that there will be a difference between opening a single *.nc file or a xfdumanifest.xml file?


#8

Thanks!
This solved the problem.