Sen2cor 2.10.01 - Product metadata file cannot be read with 14.2 baseline L1C

Hello all,

I’m trying to run sen2cor 2.10.01’s L2A_Process command on an older product (S2A_MSIL1C_20170811T085601_N0205_R007_T35TME_20170811T090657, it’s the 14.2 baseline) and it fails out with “Product metadata file cannot be read”. I can run 2.09.00 on the same directory without issue. Both are using their respective default sen2cor configs, and this is running on Linux. If it helps, this was downloaded using the sentinelhub Python package, latest version - I would normally blame that package, given the changes in the 14.9 baseline, but I can’t explain why 2.9 would work but 2.10 wouldn’t. I am able to run both 2.9 and 2.10 against a more recent product (S2A_MSIL1C_20220120T091311_N0301_R050_T35TMG_20220120T111422) without problems.

Hello @creffett

I confirm that I recieve the same message as you when I uses 2.10. But I am able to process the L1C Tile (S2A_MSIL1C_20170811T085601_N0205_R007_T35TME_20170811T090657.SAFE) with 02.08.

I have checked the L1C in SNAP and it appears to be OK in its formatting. I will check the Product metadata against a more recent product.

Cheers

Jan

Jan Jackson
OPT-MPC Technical Manager

I had the same problem with v02.10.01. I switched to v02.05.05, and it worked!

@Jan by chance did you have the time to solve this bug after 4 months?
I’m still getting this error using Sen2Cor 2.10.01 on UNIX Ubuntu VM.

I would like to avoid downgrading the Sen2Cor version

thanks in advance

Hello @sylar11

The Sen2Cor developers have identified the cause of this issue and are working towards a fix.

Jan

Jan Jackson
OPT-MPC Technical Manager

3 Likes

thanks a lot @Jan
I will look forward to a fast and efficient solution!

regards