Sen2cor (detailled instructions)

Hi ABraun,

could you maybe check if this process is still necessary or does work differently for sen2cor 280?
It seems to relate the SEN2COR28_BIN Key to the correct folder, which also seems to be created during installation. Therefore there is no more SEN2COR_HOME Key, which I tried to create.
I did this because I have installed the plugin and the bundle and somehow I dont get it executing the correction algorithm inside SNAP.
So I tried this manual as it stated to work with later versions.

Do you have a clue, why I don´t get sen2cor working?

Help would be greatly appreciated!



I’m not sure to be honest, sorry. Maybe one of the sen2cor developers can answer this.

1 Like

thanks for the answer. Do you know how I could contact them?
I would like to find out how to include the usage of sen2cor inside SNAP in order to being able to work on atmospheric correction for teaching purposes.

Thank you and have a nice day

they keep an eye on this forum actually.

Running sen2cor from the command line is much more uncomplicated and I recommend it so you can continue in case they need time to answer.

Hi Konrad,
how are install the plugin and bundle?
What’s your OS?
If we install with external tool manager of SNAP, the bundle is installed in the .snap folder. The SEN2COR28_BIN variable is used like root folder of the Sen2cor executable and also the working folder that it was separated in the past version with a another variable SEN2COR_HOME.
Please, could you post the error as a screen shot of ouput command in SNAP?

Hi Florian,

sorry I don´t remember what was the exact issue back then. Generally I think we resolved it by specifying the path variables correctly, which was even possible within the SNAP GUI using Windows10. Depending on how you install sen2cor it is placed in different folders. Most of our students use the FORCE software on Linux systems now for atmospheric correction and I am using radar data from Sentinel-1, where there is no clouds visible ;). I hope you managed to fix it!

Hi Andreas

I’m going to follow your steps and I have SNAP 6.0 downloaded, but I can’t find the 2.4 sen2cor version. Any idea?
Thanks in advance!

Sorry, I would never recommend to use an old version of SNAP, these instructions were just documented when SNAP 6 was the latest version. Same applies for sen2cor. But the steps should work regardless of the version.

Ok, thank you very much

I will follow the same steps with SNAP 8.0

What are the steps to install sen2cor 2.08 in SNAP 8.0?

I’d say this one is still the most robust and clean way to do it: Sen2cor (detailled instructions) - #2 by ABraun

After following the steps provided, when I click the Run button, the execution output remains blank. How long does it usually take for the process to start and finish??

Actually, it should start immediately.

You can also run sen2cor from the command line, this works reliably.

Instead of 2.8 I installed 2.5 and it worked. I hope there is no much difference in the outputs of the two plugins though.

It is better to start a new thread with a descriptive title so your post gets the attention of someone familiar with your specific issue.

You should mention enough of the details of your platform, SNAP version, update status, and the data you used to allow others to reproduce the problem. Also please post error messages as text rather than images to help those who encounter the error in the future (the search engine does not recognize text in images).

The screen snapshot mentions an error in the metadata, which is probably the root problem behind the missing attribute ‘SPACECRAFT_NAME’. This could be due to using a file format with limited metadata support (GeoTIFF), a corrupt file, or an unsupported data set. The image mentions a report file which probably provides more details. If you need help understanding the report file, please attach it to a post.

Please take a look here:
Sen2Cor error - “SPACECRAFT_NAME” - s2tbx / sen2cor - STEP Forum (

1 Like