Sen2cor not producing L2A products

I am trying to execute sen2cor tool and the observation is “wrong operation mode:None. Finished tool execution in 2 sec”. Please advise.

Attached is for your reference.

Information: When i execute L2A_Process.bat --help in command mode of system and esa snap command mode, In both cases-No errors found.

have you tried the solution provided in this tutorial Sentinel-1 TOPS interferometry on page 17?

I just tried above suggested option - No improvement.
Then, I did complete uninstall.
Re-Installed and tried to execute sen2cor - Not producing L2A products.
Only improvement I see now is “1files copied” - Attached for your reference.
Please advise.

hmm, strange.

Have you seen this instructions? Sen2cor (detailled instructions)

Yes, I followed.
May be I am not having much knowledge to follow as it should be.
Please let me know if you need any screenshots, logs etc to guide me.
Thanks for your support.
Please advise.

In continuation to above issue, please see this exception.
attached log and screen shot is for your reference.

messages.log (92.4 KB)

Python is being blocked and hence the SNAP issue (Attached for reference).
Thank you for your support and time.
Now I am getting L2A products.

1 Like

I have already installed and tried both standalone sens2cor v02.05.05 and sen2cor v2.8- win64 versions on my notebook. I’ve tried both with old and new tiles of Sentinel 2 images. Sen2cor seems to processing pretty well without any wrong messages during or at the end of execution as might be expected in the log file. The problem is that when I try to see the images results using the metadata *.xml archive it doesn’t work with erros messages for each bands individually. I have to use product explorer to each img_dat archive to view the images of each band. I suppose that sen2cor do not write the metadata header archives correct and at the end of the process. I need help to understand and try to solve the problem. thanks in advance.