SEN2COR tool

Hi @Gabriel,

it seems that you are trying to run sen2cor using as input a granule, you have to use as input a L1C full product.


After a quick look I saw that nobody answered your question… I also dont have an answer but I am facing the same issue…
After batch processing around 100 images with Sen2Cor I noticed that the cache folder took over my disc space… I was also wondering how this can be avoided and if the cache could be deleted.


Hai Ralf,

I am trying to install sen2cor from two weeks but not able to do that. Can you please help me to install sen2cor and make it working on my PC using teamviewe software. Please help me out.

I´m using Sen2cor in SNAP and I´ve the same problem in my two computers…

In the middel of the process…

File “C:\Anaconda2\Lib\site-packages\sen2cor-2.4.0-py2.7.egg\sen2cor\”, line 205, in process
if(sc.process() == False):
File “C:\Anaconda2\Lib\site-packages\sen2cor-2.4.0-py2.7.egg\sen2cor\”, line 830, in process
if(self.tables.sceneCouldHaveSnow() == True):
File “C:\Anaconda2\Lib\site-packages\sen2cor-2.4.0-py2.7.egg\sen2cor\”, line 2461, in sceneCouldHaveSnow
from PIL import Image
File “C:\Anaconda2\lib\site-packages\PIL\”, line 56, in
from . import _imaging as core
ImportError: DLL load failed: No se puede encontrar el módulo especificado.

I think I´ve installed everthing without any error…

any idea?

thank you very much!



I used the Standalone version and I could finish the process…

I hope we can use the snap6 and sen2cor soon without problems!


You need to mention the path of python.exe. With me it is Anaconda Installation. C:\Anaconda2\python.exe

Dear All

I am having some problems opening corrected output image from Sen2Cor in SNAP. I get the following error:

The image was corrected using Sen2Cor 2.5.5 and I am using Snap 6. I am also concerned about the errors in Sen2cor, Windows 10 (using PowerShell)

Should I be worried about these errors?

Hallo MahlatseK,

you should be worried about these errors since you cannot open and analyze your result. I assume you tried processing at 10 m spatial resolution only. If, then you should try to process again for all spatial resolutions. You may have a look to the problem report Sen2Cor-02.05.05-win64 - AttributeError: 'L2A_Tables' Object has no attribute '_L2A_Tile_PVI_File' where this is discussed in more detail. I hope this will help you and solve your problem as a workaround until the bug is fixed.

Thank you very much for the advice, I can confirm that I managed to run sen2cor without no errors following steps provided. However I am still unable to open the product in SNAP 6 getting same error as above.

Hi @MahlatseK,
have you updated SNAP? The new format is supported since version 6.0.1.

I have updated now its working like a charm :slight_smile: Thank you a lot.

Dear SNAP Users,
I need some help regarding the Atmospheric Correction of Sentinel 2 data!
I am using ESA SNAP 6.0 (with sen2cor plug-in) for the Atmospheric Correction.
The image, I want to process is from 2015 and it’s showing the Error “L1C user product directory must match the following mask: S2?_MSIL1C*.SAFE but is: S2A_OP~1.SAF”; which is not happening for the recent images (e.g. images acquired in 2018)!
I know this issue is because of the long file name!
And I tried to change the file name as suggested in the Error message, but then also it’s showing Error “Product metadata file cannot be read”!

Any suggestions on how to resolve these issues to do the atmospheric correction of Sentinel 2 images acquired in 2015!

Thanks in Advance.

Instead of renaming the data folder, you should move it to a directory with lesser subfolders, e.g.

The folder name after extraction should remain as it is.

1 Like

Thank you so much for your response.
It’s working now.

hello how i do citation for sen2COR

Hello everyone!
I installed sen2cor 5. I run atmospheric correction for all resolutions (60,20,10) (for standalone users). After the process that terminated succesfully a folder S2A … was created , were MTD_MSIL2A was exeisted in this folder. I tried to open MTD_MSIL2A in snap but the re was the bellow message

Please can anyone tell me why that happened? and how can i solve it?

Have you tried to update SNAP? (Tools -> Plugins -> Updates) There was an evolution of S2 level 2 format and it is supported from version 6.0.1

Thanks for the answer, I will try again after the updates!
thanks in advance

finally the problem is not the update. I have the same error

Result of sen2cor is added in product explorer named by ‘Output product’. Then i am trying this result save as product, but not saved my result. What is wrong steps?