Smos ee file to NetCDF

I’m attempting to use the SNAP SMOS tools to convert L1C SMOS data (.zip) to NetCDF format (File-Export-SMOS EE files to NetCDF, but it opens completely without a reaction (blank or stuck, as show in the picture). Is the SNAP software not installed properly? or some other problem?

I also tried calling the SmosNetcdfExport with GPT according to the userGuide (NetCDF Format Conversion), but I kept getting illegal typing errors:
C:\Program Files\snap\bin>gpt SmosNetcdfExport E:\SMOS\Inputfile\
Error: Illegal input: E:\SMOS\Inputfile\

Hello yqinss,

we have tried to reproduce the problem.
With the latest SNAP (all updates) and installed SMOS-Box the product you are referencing works.

That the GUI shows the strange [rad?] in your case indicates that something is not correctly setup.
Could you try a clean reinstallation of SNAP and SMOS-Box. First uninstalling SNAP (deleting all SNAP user data) and then install fresh.

Hello Marpet:
Thanks for your reply. I’ve tried uninstalling, reinstalling, and updating SNAP, and the SMOS GUI still hasn’t improved. Interestingly, when I specify the bounding box to be executed with the default options, it can output the file. After that, the SMOS GUI returns to normal. However, the same problem occurs if SNAP is opened again.

Could provide the log file please.
How and where to find it is explained in the FAQ.

Is it a log file at run time? Like this picture?

updater.log.0 (377.7 KB)

messages.log (76.5 KB)
messages.log.1 (799.4 KB)
messages.log.2 (1.0 MB)

Thanks for the logs.

The problem you show in the image indicates that you don’t have write permission to the directory where you want to write the data.

The log files show some strange errors like this.

com.bc.ceres.binding.ValidationException: Value for 'East bound' is out of range [-180,180].
( = excluding; ] = including; *= max value
	at com.bc.ceres.binding.validators.IntervalValidator.validateValue(
	at com.bc.ceres.binding.validators.MultiValidator.validateValue(
	at com.bc.ceres.binding.Property.validate(
	at com.bc.ceres.binding.Property.setValue(
	at org.esa.snap.ui.RegionSelectableWorldMapPane$RegionSelectionInteractor.updateProperties(
Caused: java.lang.IllegalStateException

This needs some more investigation.