[SNAP 8.0] Installation fails with SNAP Command-Line.lnk failure message

Hello
I’m just trying to update from SNAP 6.0 to SNAP 8.0 on my Windows 10 laptop (64 Bit, 16GB RAM) and I recieve this message:
image

Trying again does nothing, and cancelling reverts me back to SNAP 6.0. I did not configure SNAP for use with Python when asked. And I have tried both not delting, and deleting the old configuration when asked. This has happened three times now.

Can anyone shed some light, please?

Thanks in advance

Jan

Jan Jackson
S2 MPC Operations Manager

Were you installing with administrative privileges?

I have a system with what appears to be the same problem. My system is “Windows 10 Enterprise managed by our IT people”. I was able to install SNAP 7 without administrative privileges, but get the same message attempting to install SNAP 8 (without administrative privileges). “Yes” to try again just loops and “Cancel” reverts to SNAP 7. Our IT people
deal with this sort of issue by wiping the system and letting users reinstall their apps.

1 Like

Hi George @gnwiii
Thanks for your response.
It was my understanding that SNAP didn’t require elevated privileges, but this is a new (new compared to my previous Windows 7 laptop) but perhaps you’re right. I’llcheck with my SysAdmin.

Cheers

Jan

Hi, I’m having the exact same problem.
I’ve tried installing Snap 8.0 in parallel to Snap 7.0 (instead of updating the previous installation) and it did not work either.

I installed SNAP 7 without administrative privileges. I would expect the Command-Line.lnk entry to go into %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs. One possibility is How to unclutter the Start menu wich suggests moving entries from the above location to the c:\ProgramData tree. I didn’t do this myself, but IT may have made the change – perhaps so it is easier to track things users have installed.

I just tried installing SNAP 8 again, after uninstalling and reinstalling SNAP 7. The entry for SNAP 7 under c:\ProgramData went away over the weekend, so I assume IT’s automatic maintenance removed it. The installer has an option to create a start menu entry. I selected %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs, but still got the “Cannot create” error for the c:\ProgramData location. Then I ran the install without requesting a Start Menu entry and it appears to have been successful. SNAP started, and downloaded updates. When I tried to restart I got a message that network access to both Public and private networks is blocked for SNAP (with option for admin to override the settings).