SNAP 9.0 released

The ‘snap9_changelog’ link in the original post is a SNAP’s ‘Issue Navigator - JIRA’

Yes, that’s intended. Do you expect something else?

Yeah, sorry, usually there are some text files with concise overview of progress made. At first I thought that there are some open issues simply. Now I see that there is a filter which concisely combines all the tasks done for version 9. All good, thanks.

1 Like

Dear @oana_hogoiu and @marpet ,
thank you for the new release and all the improvements.
Unfortunately, I am having issue to install it correctly. After the installation I don’t see anymore the tab “Polarimetry” with all the several tools in the Radar tab.
I have downloaded the installer from here

as @marpet suggested, but no lucky at the moment.
I am working with a Windows-64 machine and also uninstalling the old versions of SNAP there is no success.
Thank you in advance.

S Savastano

Dear @s.savastano can you show us what you have in the Radar menu?
The Polarimetric entry should look like this:

Did you clean all SNAP cache before the installation?
C:\Users\[username]\.snap
C:\Users\[username]\AppData\Roaming\SNAP or C:\Users\[username]\AppData\Local\SNAP
C:\Users\[username]\AppData\Local\Temp\snap-[username]

Thank you @oana_hogoiu for your quick reply.
I can’t print my screen right now but that’s the point: opening the tab radar “Polarimetric” and “Soil Moisture” are missing.
I thought was an issue related to SNAP 9.0 and so I tried to reinstall SNAP 8.0 but it’s the same and I can’t see them.
Anyway, I am firmly sure that everything was there in my old version (8.0) before installing the new version.
Are you suggesting deleting all those folders?

S Savastano

I can’t print my screen and I don’t understand why.
This is from the radar tab…

You should try running chkdsk and then Disk Cleanup, to ensure the issue os not a result of a filesystem problem, then reinstall with the option to delete all user data (make a backup of any files you want to use in the future).

1 Like

Dear @gnwiii and @oana_hogoiu ,
I followed your suggestions removing those folders, running chkdsk (no errors) and Disk Cleanup, and finally reinstalling SNAP 9.0 deleting all user data but unfortunately no luck again.
The weird thing is that also doing the same with SNAP 8.0 I had the same problem.
Any other tips to solve it?
Thank you in advance.

S Savastano

Could you provide the log file? This might contain some useful information.
Please have a look at the section Read This Before Posting for an explanation how to find the log file.

Dear @marpet ,
this is the log file after the installation.

messages.log (73.9 KB)

Thank you.

S Savastano

Hi Salvatore,
The “Polarimetric” and “Soil Moisture" are provided by the RADARSAT Polarimetric Toolkit (rstb).
It seems this is not installed on your system. At least it is not shown in the log.
Have you disabled it during the installation process?

You can get it after installation by the plugin manager.
Go to Tools / Plugins. In the Available tab you probably find the entry Radarsat Polarimetric Toolkit Module. Install it and do a restart of SNAP. Then the menu entries should be back.


In my installation it is already listed as installed.

2 Likes

Hi Marco,
thank you for your quick reply and to have solved out the problem.
Yes, you are right. Because I work mainly with S1 and S2, during the installation clicking on Radarsat toolkit, S1 one was disabled. So stupidly, I continued to install SNAP keeping active S1, S2 and S3 toolkit and disabling Radarsat one.
Anyway, following your suggestion it is working correctly and all the tabs are there.
Thank you again for your help.

S Savastano

1 Like

Which is the Python version that can be used to install and work with snappy for snap 9.0??

Hi Antonio,
Python 3.6 should work out of the box.