SNAP cannot read MTD_MSIL1C files

I have downloaded sentinel-2 images and SNAP version 6.0. However, I am not able to open the MTD_MSIL1C file.
Any suggestions please?

1 Like

Can you please describe your issue a bit more? It’s hard to help without any information.

Where did you download the S2 image?
Which product name?
How did you try to open it?
What error occurs?
Any error message is given?

it says unable to get metadata from JP2 images associated to product MTD_MSIL1C.xml

I have downloaded the data from both EarthExploreer and GLOVIS and I am facing same problem

The official source is this:
Might be worth a try in order to exclude the data format as an error source. Sometimes, data hosted on these portals was processed differently.

Was your download complete, correctly unzipped and are there image files in the GRANULES folder?

What product level did you select?

yes download was complete and correctly unzipped. i have repeated the download process four times twice from each. there are images in the GRANULES folder but again I am not able to open using either SNAP or any other image processing software. I have downloaded sentinel-2 products.
the copernicus open hub website does not include images of the whole study area and this is why i excluded it from the download.

With product level I meant 1A, 1B or 1C:
I wonder how data can be available in the other portals if it is not hosted on the copernicus hub. Maybe the folder structure of the data from USGS is different and the data is not found by SNAP. But I can only test if you name me the exact product name you downloaded so I can try it myself.

while data from the other portals is available and downloadable. the products used are 1C

I do get results for the time from 01.01.2018 until today:

What is the exact date of your image?

when i chose cloud cover from 0 to 10 no products appeared

The metadata is not very precise to be honest and sometimes the cloud cover refers to the whole S2 product (instead of the single granules).
Simple enter the date of the image you downloaded from USGS and you will find the corresponding image in the Copernicus Hub.

I have downloaded few images from copernicus hub and I uninstalled and reinstalled SNAP but unfortunately, i am getting the same error message " unable to get metadata from JP2 images associated to product MTD_MSIL1C.xml"

1 Like

please give us the exact name of the product you downloaded from the Copernicus hub so we can test the data.

If you copy and paste the name here, we can insert it in the search bar and download it directly.

this is one for instance

and here is another


Hi, I have just downloaded and it is working properly. Have you tried to open directly the zip product? Which tool are you using to unzip? If you try to open the jp2 files inside the folder …\S2A_MSIL1C_20181108T070101_N0207_R063_T39RZH_20181108T081646.SAFE\GRANULE\L1C_T39RZH_A017649_20181108T070101\IMG_DATA , are the opening properly?

thank you, I just tried it and it works fine for me. So the data is not the issue here.
Where did you download SNAP?

I use WinRaR to unzip the product. I opened the zip file using SNAP and its working now
Wow never thought that using a certain unzipping tool could cause this much trouble