SNAP freeze seconds after it is opened


#1

I installed the last version of SNAP (http://step.esa.int/main/download/), with no problems during the installation wizard progress. When the aplication is execute, it opens (apparently) with no problems, but seconds after the principal window appears, it freezes. I can’t do anything when this happens, if the window is minimized, the next time it is maximize it shows a black background with nothing on it.
I tried to close de windows with the cross in the corner but nothing happens, it only closes when I excute the windows Task Manager and force the shut down of the process.
I’m working with a Windows 7 enterprise SP1 64 bits i5, 4gb ram, python 2.7.

someone has any idea about this?

Thanks at advance

Fede


#2

Doesn’t sound good.
Can check you the log file?
It is located in %APPDATA%\SNAP\var\log. Just copy this path into the file explorer.
Start SNAP to ensure that the error is logged into the log file.
After closing SNAP check the file messages.log and attach it here. Maybe we can see helpful information.
One other thing you can try is to check if the driver for you graphics card is up to date.


#3

Ok. Thanks a lot for your answer.
I just upload the file message.log (replace my pc username with Usuario).
messages.log (68.0 KB)
Before this, I uninstalled the SNAP and its modules and then reinstalled it, upgraded the Intel ® HD graphics 2500 driver, and finally while the insallation wizard was running, I turn of the ESET antivirus.
I hope this may help you to study the problem.


#4

The log you have attached looks pretty much like mine when SNAP starts normally.
But I have heard this behaviour once before, a colleague had this issue. (I think the problem is gone, meanwhile). Maybe she can shed some light on it, but I can not talk to her before Monday.

I hope I can get back to you on Monday with better news.


#5

Thank you so much.
I will be waiting patiently for any posible solution.
I work with the NEST in the same machine and I never had any trouble.
We are talking next monday. Have a good weekend.


#7

Hello, everyone…
Continuing with the problem, It looks like it has something to do with the user permissions.
In my work, for security issues, every worker has its own user.
When I work in the same machine with different users, SNAP works properly in the admin one desktop, but when it is open with another user, it get freeze.
I’m still trying to figure out how to solve the problem but I think this is a little step foward the solution.
cheers.


#8

Thanks, for sharing this information.
With NEST/BEAM we had more control over the things which happen.
With the switch to the NetBeans platform, we lost this control in exchange for several other useful functionality.
The NetBeans platform stores information in <user_home>/.snap. But some information is stored in %APPDATA%\SNAP on Windows.
Do you have only a problem when two or more users are active or does it freeze always with the user accounts?


#9

I have the same problem… This is my log messages.log (57.7 KB).

@marpet can you help me?

thank you so much.


#10

Does your Linux run in a Virtual Machine? It might help if you enable 3D graphics support., if possible.
Sometimes the world wind module generates some trouble.
Have a look here: