Toolbar issue on MacOS Ventura

Hello everyone,

Anyone facing ESA SNAP toolbar issue on MacOS Ventura? I keep on clicking here (attached image), but nothing comes out.

Thanks

2 Likes

Hi,

I haven’t heard about it till now.
It seems that other applications have similar issues with MacOS Ventura on ARM CPU.

I also have a couple of questions
Are do you have an M1 CPU too?
Is it a fresh SNAP installation or did it work before? Which version of SNAP have you installed

Has someone else experienced this and maybe found a solution for it?

Hi. Yes. It’s M1.
I use version 8. It worked fine before. It’s not working in Ventura anymore.
I also tried fresh installation of Snap 9. Same issue.

With M1 there are still issues here and there. Especially with applications not explicitly made for this chip.

In the short term we can’t help. The only suggestion I can give is to revert to monterey.

I’ve created a ticket for this:
[SNAP-1571] Application menu entries with MacOS Ventura (M1) not shown - JIRA (atlassian.net)

1 Like

Issues have been reported for Java appllications other than SNAP (e.g., these Universal gcode sender for CNC issues . One of these issues reports:

Warning: the fonts "Times" and "Times" are not available for the Java logical font "Serif", which may have unexpected appearance or behavior. Re-enable the "Times" font to remove this warning.

You might want to look at messages.log files on your system. You may get useful advice on Apple Ventura user forums (you should mention that SNAP is a Java application for Intel macOS).

Hi,
I am facing the same issue in ESA SNAP macOS Ventura. I have tried downloading versions 8 and 7 also but nothing comes down from the toolbar on the top.
Thank you

I’ve deleted you other post as it is a duplication of this thread.
And as I said earlier in this thread there is no solution to this Except reverting to monterey.

thank you.
downgrading to Monterey will it create a problem to the laptop

I have no idea. I’m not using a Mac. But I heard this suggestion in other forums.

ok. Thank you so much.

Hi, I’ve just experienced the same problem with my MacBook in ESA SNAP for macOS Ventura. Also, I have problems in closing and managing the SNAP’s window on the screen, and in selecting the items not in the toolbar. I really don’t know how to solve it now

SNAP now has 3 people reporting problems on Ventura, but the reports lack detail that might connect the problem to those being experienced with other apps on Ventura. It would be useful to know if the affected systems all use Apple silicon, and whether there are reports for missing fonts in log files.

Affected users should report the problem to Apple support, or at least enable automated problem reporting in Ventura and run SNAP to generate a report.

Apple user forums for Ventura (on your hardware) may be more helpful than this forum.

Yet another Java app with display problems: the problem occurs on both M1 and Intel processors and is due to a change in the support for OpenGL.

Hi

I also recently upgraded to Ventura and cannot use SNAP any more. Clicking on menus will just not open anything.
I’m using Intel version, 15 inch MBP 2019.
So, it is not an ARM/M1 problem.

Best
Andres

Hello Everyone

Im also having the same issue with SNAP in Mac OS Ventura, I have tried Older versions like SNAP 7.0, 8.0 but the issue remains the same with new M1 chip.

The problem affects Intel systems running Ventura as well as other Java applications. You should look for a solution on Apple forums.

1 Like

Just an update from my end. I recently updated to Ventura 13.0.1 but the problem still exists. I’m using a Windows-based laptop to use SNAP. If you downgrade your Mac OS to Monterey, the SNAP will work fine.

2 Likes

Thanks for all the reports.
May I ask you to report the issue also to Apple?
I don’t know if this issue has been introduced due to a mistake or of Apple intentionally dropped some support for Java.
If it is a mistake, they might fix it.

Hi

Seems that the Eclipse issue, mentioned above, has been solved (and no, not by Apple).

Some messages from log, would be interesting to know if a properly working version of SNAP gives similar messages?

WARNING [org.openide.filesystems.Ordering]: Found same position 550 for both Menu/File/Import/SAR Sensors/org-esa-s1tbx-io-importGaofen3.shadow and Menu/File/Import/SAR Sensors/org-esa-snap-dataio-envisat-ImportErsSARProduct.shadow
WARNING [org.openide.filesystems.Ordering]: Found same position 80 for both Menu/File/Export/Other/org-esa-snap-rcp-actions-file-export-ExportImageAction.shadow and Menu/File/Export/Other/org-esa-snap-rcp-actions-file-export-ExportKmzFileAction.shadow
...

Just starting SNAP on linux I get 63 different WARNING [org.openide.filesystems.Ordering]: Found same position lines.

2 Likes

Yes, those messages are always printed
The Eclipse issue seems to be resolved.
But I couldn’t track what they have actually done.
And maybe it is more like a workaround. For another application, without knowing exactly, it seems they did something different to solve it…