SNAP hangs at startup

I’ve installed SNAP 3.0 on my Windows 7, 64-bit 4-core HP laptop with 8 Gb RAM. I’m using Java 64-bit version 8, build 91 (build 1.8.0_91-b15). There’s plenty of disk space available on the laptop’s hard drive.

SNAP starts, builds the application graphical elements, but then hangs and won’t receive any user interaction. I’ve uninstalled and reinstalled both Java and SNAP, but with no joy. The application window holding SNAP can be interacted with and the Windows Task Manager reports that the application is ‘Running’, but SNAP itself doesn’t respond, which suggests it’s a Java related problem.

Has anyone any clues to what a solution might be? When I kill the application, the Windows problem reporter provides the following output.

Thanks - Stephen

A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: snap64.exe
Application Version:
Application Timestamp: 51174cd8
Hang Signature: ee13
Hang Type: 6144
OS Version: 6.1.7601.
Locale ID: 1153
Additional Hang Signature 1: ee139189d68582e8782f684b1a9afdad
Additional Hang Signature 2: 272c
Additional Hang Signature 3: 272c52c45d6990a4646ae88eab7bc8ab
Additional Hang Signature 4: ee13
Additional Hang Signature 5: ee139189d68582e8782f684b1a9afdad
Additional Hang Signature 6: 272c
Additional Hang Signature 7: 272c52c45d6990a4646ae88eab7bc8ab

Thanks for this report, Stephen. I haven’t heard of this behaviour before.
Your local Java installation should actually not interfere with SNAP. SNAP brings its own JAVA instance.

Is it you first SNAP installation you have you installed SNAP 2 before?
You can try to delete the .snap and the SNAP folder.
.snap is located in your user home folder and SNAP is located in <USER_HOME>/AppData/Raoaming.
Maybe there is something old cached which blocks the execution.

maybe it is a java runtime issue.
in some cases it is recommended that:
however the operating system is 64 bit but install 32 bit java runtime to let some application work fine.
I hope your problem will be solved.

Dear all,

Me too… having the same problem…SNAP starts, builds the application graphical elements, but then hangs and won’t receive any user interaction. I’ve uninstalled and reinstalled SNAP, but with no luck.

Have you solve these problem… If so can you please share it .

Thank you

Could you do a little test please.
Disable your internet connection before starting SNAP, either by removing the LAN cable or switching off the WiFi connection. Thanks


As you have mentioned, I disconnect the Internet cable before starting SNAP. First time the application go closed by itself and the second time its was unresponsive again.

I will tried if again using my other computer and see.

Thank you !


I’m wondering if it might be caused by the issue mentioned here:

At the end it is mentioned that being disconnected can help.

If you resize the window is the content still redrawn or does it become black or white or whatever color?

Yep, disconnecting the LAN and wireless network adapters before starting SNAP allows SNAP to work correctly. However, I lose access to the network drive containing my imagery…

I might try downgrading my JRE to something even older (I only went back to Java 1.8 build 82 before), to see if the dependencies that the SNAP Java instance uses are causing the issue.

UPDATE - keeping the existing version of Java, but disabling proxy access by setting ‘No Proxy’ in the ‘WWW’ options in SNAP allows SNAP to continue working, and to access the network over the LAN. It’s an interim fix, but it prevents the user interacting directly with the interweb through SNAP.

1 Like

Thanks for testing this. Good to know that a work around is possible, even if it is not perfect.

From this Java issue I see that it is already existing in 1.8 build 25. And still not fixed.

Have you update the jdkhome property in the etc/snap.conf file or exchanged the jre folder within the SNAP installation? Otherwise the new Java installation will not be used by SNAP. For your information SNAP ships 1.8 build 60 of Java JRE.

Meanwhile we have updated all our machines to Windows 10. But we haven’t experienced this problem before. So I think this is not only a Java problem. Probably something else in combination with Java causes this problem otherwise more people would be affected.