SNAP2StaMPS version 2: new features and new sensors supported

As announced yesterday at the FRINGE Workshop 2023, we have released the expected official update for the snap2stamps package including new features and extended the sensors supported.

Our new partners Jonas Ziemer and Clément Dubois contributed with their adaptation of the snap2stamps in the called TSX2StaMPS which has been included and enhanced in this new version 2 of the snap2stamps package.

You can already start using the new package by downloading either from the GitHub repository or its zenodo .

Please use the new doi to reference the package when needed.



Hi @mdelgado i used ubuntu 22.04 LTS and snap2stamps v1 many years.

i tried to install new version of snap2stamps bu i took this error;

sudo apt install git libfftw3 libgfortran
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
E: Unable to locate package libfftw3
E: Unable to locate package libgfortran

Than i tired to install libfftw3 manually like this video

Than i tried to again install to environment.yml but i didint succeed.

conda env create -f snap2stamps_environment.yml
Collecting package metadata (repodata.json): done
Solving environment: failed


  • fftw3

Do you have any solutions?
Thank you…

Ouh! Interesting…
Let me check it and I will update on GitHub the correction

Regarding the package not found for Ubuntu 22 let me check because indeed I think I use Ubuntu 20 instead.

Let me update it and come back to you in the next couple of days.

This is fantastic Jose Manuel! Let’s make sure it works with SNAP 10 which will be released by the end of the month.

1 Like

I have search on Google and I found that for Ubuntu 22.04 (I will include this in github as it was reported for Ubuntu 20.04 ) the correct packages are the following:

sudo apt-get install fftw-dev
sudo apt-get install gfortran

Regarding the conda library install issue of fftw3, I have remove it as in fact only its installation on the OS is needed.

Thanks for reporting it. Now it shall be solved. Let us know.

Hi @mdelgado

i have some good and bad news. I start bad news:
the last update for ubuntu 22.04 didnt worked for me i took this error message when i started to sudo apt install fftw-dev

Building for 5.19.0-41-generic
Building for architecture x86_64
Building initial module for 5.19.0-41-generic
ERROR: Cannot create report: [Errno 17] File exists: ‘/var/crash/nvidia-dkms-515
Error! Bad return status for module build on kernel: 5.19.0-41-generic (x86_64)
Consult /var/lib/dkms/nvidia/515.65.01/build/make.log for more information.
dpkg: error processing package nvidia-dkms-515 (–configure):
installed nvidia-dkms-515 package post-installation script subprocess returned
error exit status 10
Processing triggers for initramfs-tools (0.140ubuntu13) …
update-initramfs: Generating /boot/initrd.img-5.19.0-41-generic
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

i tihnk this error about my pc settings.i will look again.

Goods news: i tried new update in ubuntu 18.04 and it works fine; auto downloader py., master and split py. worked and created .dim files. But when i came step3 ‘‘coregistration’’ this error was occured:
[8] Processing secondaries file :20230707_IW3.dim

Executing processing graph


[8] Finished process in 3.323873996734619 seconds.
Returncode :1
Error computing with coregistration and interferogram generation of splitted secondaries /home/suat.coskun/snap2stamps/split/20230707_IW3.dim

i attached my .conf file. Thank you for replay…
project_topsar.conf (1.7 KB)

Hi suat,

Can you please verify 2 things:

  1. with the log you put here it seems to be it failed only on the pair 8
  2. the MasterSplit folder exists and it has files which size is higher than 0 bytes.

Regarding the error you mentioned related to the Ubuntu OS please check, as in fact it seems you have nvidia issues which are not related to snap2stamps.

Please let me know.

Hi @mdelgado

When i selected area of interest in two IW (IW2 and IW3) something was changed Step3 ( worked!!! Ifg and coreg .dim files was created but when i checked this files i saw SNAP didnt made subset. It processed full bursts for diffrent IW’s. When i selected aoi only one IW step1 and step2 worked fine but step3 didnt worked again. Maybe problem was about subseting.

Note: i used ununtu 18.04 and SNAP 9.0 and 8 SAR images for test.

ERROR -STEP3 for one IW (This error occured all images.)

Could you please try to execute the graph2run of the coreg step that is generated in the run that generates the error?

please run : gpt -c graphs/coreg2run.xml (or similar)


Sorry @mdelgado but i dont understand what do you prefer to me? Bu i think it is about topsar_coreg_ifg_computation_subset.xml files because script dosent start this graph.

Thank you…

Please find the file coreg_ifg2run.xml that should be found inside the PROJECTFOLDER/graphs folder.

Execute it using gpt using a command like : gpt -c 16G PROJECTFOLDER/graphs/coreg_ifg2run.xml

Please change the PROJECTFOLDER accordingly I think you are using /home/suat.coskun/snap2stamps/

Let me know the output.

Hi @mdelgado

This time i tried to change my aoi for only one burst and its worked. Than İ followed your advice and ran gpt.

After that i started whole process for the same parameters but i changed my aoi for two burst. i took the same error. Step1 and step2 ran correctly but step3 got the same error.

Note: At the end of the line you wıll see gpt coreg2eun:xml error.


Thanks! I see… apparently the package contains the old xml version of the step3.
Let me update it quickly and thanks for rising the issue here.

This afternoon the github and zenodo will contain the updated xml and I will kindly ask you to test it.

At least you confirm that for single burst the whole workflow works. Thanks for the effort

Please try now!
Let me know

Everythings looks fine @mdelgado !!!

1- Before I tried single burst process and its worked
2- I tried two burst process and its worked.
3- I tried multi-subswath process and its worked.

But i have one last question about multi-subswath process. When i checked results of ifg folder i saw full bursts process. Scripts didint made susbset like my coordinates. But when i export for them (step5) and process it with STAMPS, i plot for timeseries and saw only my aoi cordinates border processed (not all the bursts area) How colud this be done and How multi-subswath script run generally?

Finally thank you for all quick response and this amazing scripts…


1 Like

A question came to my mind. How is the scripts select Master image or what is their criteria? İ created a stack between 11.2019 to 07.2023 totally 105 images. SNAP selected master image 20211009, selected 20200429. Why did they selected different acquisition date?

The snap2stamps master selection is quite simple, taking the middle of the series. The user can also select the first or last.
In the future, if the SNAP InSAR Browse operation will become available via gpt, it will get updated.

:smiley: :star_struck:

Thanks also to you for being our first tester!
I want to thank you to ping point the issues that had been created mixing files while creating the final package in a hurry :frowning: . Sorry for that

The Subset can be only done after debursting that is for single IW and after merging in case of multiple IWs. The data exported to StaMPS shall be cutted over the provided AOI if all goes fine (in some cases I got some SNAP bugs which I expect to be corrected soon)

I hope I answered all the questions.
Now I wish you enjoy the package!

I started testing. Thanks to the first version, I was able to analyze my article quickly. Now we have started a new article and a new version has arrived, thank you very much.

1 Like

I analyzed the same region with versions 1 and 2. But the interferograms produced were different. I did something wrong somewhere.

The same master and slave images were used.
The study area was chosen the same.
I checked the interferograms for the same dates.