SSL/Certificate issue when using Product Library

I have the same problem as well for SMOS data. I’m on windows 10, with a freshly installed SNAP 9.0.0.

Hi, for SMOS data you actually don’t need orbit files.

Can you say more about the error?
Please have a look at the FAQ to see what is helpful to solve the problem.

Thanks for your reply! I’m very new to SNAP so i might be missing something obvious.

I’m using the Product Library with an EO-CAT login, I’ve specified all the parameters i believe need to be specified, including dates, region, collection and aquisition type. I have also tried to leave them blanc or switch dates or locations of interest but the same error keeps appearing.

I hope that clears up the situation, thanks again for your help!

Thanks for the clarification.
As this is more related to the Product Library I split the conversation in a separate thread.
Maybe @oana_hogoiu or @kraftek have a hint how to solve this issue.

1 Like

Hi @JacobV,
The error occurs because the JRE does not knowns the intermediate-ca certificate which issued the SSL certificate for EOCAT website/API.
To fix the error, the intermediate-ca certificate needs to be installed on the Keystore of JRE which is used by SNAP, by following procedure:

  1. Open the EOCAT website ( into a preferred browser (e.g. Google Chrome).
  2. Open the Developper Tools (press F12), browse to the Security tab and click on View Certificate.
  3. Go to Certification Path, select the intermediate-ca certificate issuer of the website SSL certificate (above the entry) and click View Certificate
  4. Go to Details and click on Copy to File.
  5. On the Certificate Export Wizard click Next, select Base-64-encoded x.509 (.CER) (2’nd option) and click Next, click Browse to select the directory where the certificate file will be saved and enter the name of the CRT file, click on Next and Finish.
  6. Open elevated Command Propt window (with administrator privileges), by opening Start, type cmd, right click on Command Prompt App and select Run as Administrator
  7. run the following command: keytool -importcert -file %CRT_FILE_PATH% -keystore %JRE_KEYSTORE_FILE_PATH% -alias %CRT_ALIAS%, where:
  • %CRT_FILE_PATH%: the absolute path of the preinvously saved certificate file
  • %JRE_CACERTS_FILE_PATH%: the absolute path of the Keystore file, eg: "C:\Program Files\snap_9\jre\jre\lib\security\cacerts"
  • %CRT_ALIAS%: the unique alias for the new entry on Keystore.
    Note: the default password of Java Keystore is: changeit
  1. Open SNAP and try to search products on EOCAT repository using Product Library.

This resolved my issue, thank you very much!