Stack Overview Issue

Using SNAP 8.0 in Ubuntu 20.04, I don’t seem to be able to obtain the overview information of open products. I tried using newly downloaded .zip files (s1a, SLC, IW, VV+VH), but the table remains blank after pressing ‘overview’, though I am able to add the open products.

I couldn’t find any topics where this issue came up, so apologies if the fix has already been posted somewhere!

Maybe a memory issue - how much RAM do you have?
Please try to unzip the data before loading it into SNAP.

32 GB
I was under the impression the products should not be input unzipped (for master selection). Which of the unzipped items should I add?

I had previously installed SNAP 8 and configured it with python 3, but then uninstalled and configured 2.7- not sure if that could contribute. The icon for the previous installation remains in the menu, just doesn’t open.

The tool name disappears also from the Interferometric menu after the first attempt to use it (whether or not I open any products), although the option to select and open it remains.

I tried previously using a different version of SNAP, but did not uninstall it properly (deleted the folder and did not use the uninstall file); is there anything I should check with regard to that?

the overview is working after installing libgfortran5 (now showing master image)

However, this error now comes up

and the following when I attempt to use slaves_prep.py

The first error is known.
[SITBX-847] Error “WstxInputFactory not found” caused by s1tbx-cloud module - JIRA (atlassian.net)
It will be fixed with the next version. Meanwhile it can happen that the Word View is not working. IN this case you can use the Worl Maps window.

The second error seems to be related to Python version incompatibilities.
The key differences between Python 2.7.x and Python 3.x with examples (sebastianraschka.com)
I think you are trying to execute Python 2 code with Python 3 environment.

Ok thank you, setting python 2.7 as default resolved that. However, the script now throws “ImportError: No module named pathlib”.

I did install pathlib, but before installing python 2.7 (it installed to Anaconda3), so I tried installing Anaconda2 and pathlib2. but continue receiving

“Requirement already satisfied: pathlib2 in ./anaconda3/lib/python3.9/site-packages (2.3.6)
Requirement already satisfied: six in ./anaconda3/lib/python3.9/site-packages (from pathlib2) (1.16.0)”

and the No module named pathlib error persists.

I did see this thread Snap2stamps error - #205 by Martini
however it seems my issue may be related to how I installed python. Any recommendations?

I always had problems with python 2.7 installed on ubunto 20 and more updated versions (I don’t know why)
i solved your problem by installing ubunto 18 with python 2.7. I hope I was helpful

Ah ok. It’s been ~8 months since I last attempted the process. I was under the impression it could be successfully executed now with SNAP 8 and Ubuntu 20.04. @marpet is changing to Ubuntu 18.04 the only fix here?

I can’t say, sorry. I’m not using Unix, so I have no experience whit it.
But there are some issues with Ubuntu 20.
For example:
Alternatives to libgfortran3 on Ubuntu 20.04 - s1tbx / Problem Reports - STEP Forum (esa.int)

Maybe someone else can help here further?

At this point I decided installing Ubuntu 18.04 as Martini suggested would be better all around given some other installation issues, so I’ll just go from the there. In any case the thread’s original question was resolved!

Would you happen to know which version of SNAP is more recommended currently?

I would always suggest the latest version. Version 8.0.0 with all updates installed.

1 Like