Stanford Method for Persistent Scatterers (StaMPS)

Hi ABraun, after I went through some the command line of Ubuntu, I try again install and I can install some of the package until I reach StaMPS installation package I don’t know how to install them because there are just give in a manual book and some line of code that doesn’t run in terminal command and then I try to download a code from Github could you help me explain how to continue to install StaMPS ! thank you so much for your time

you have to extract the downloaded StaMPS data first.

Hi ABraun Yes I did extract the file !!

In your commands you always refer to the tar.gz file. This is just the archive, the scripts and required parts are in there. Once they are exctacted, e.g. to home/tran/StaMPS/ you can proceed with the installation of the packages (snaphu, triangle) and edit the StaMPS.conf file.

Hi there, I try to run terminal to install, I did install Snaphu, but in Stamps-4.1 beta in image below (is that I will choose install file for installation staMPS) i did try a different way to run command line but it doesn’t work :frowning: could you help me with that thank you so much

Also I follow the from the instruction to install in ubuntu

sorry, it seems that you randomly enter commands without knowing their meaning. If the folder desktop/StaMPS/ doesn’t exist, none of them will work. People in this forum can help you when there are error messages with the software during the data processing (SNAP, StaMPS, we even covered some topics on QGIS) but there are other boards which address the basics on operating systems or command-line syntax.
Maybe you can ask an IT administrator in your institutution who will assist you in installing the packages.

yes ABraun, Thank you again to your time!!

Hello @ABraun

Did you solve it?

I have similar error, When I upload my project folder, it loads up to 50% and nothing happens, I get some errors where it says not find the file ‘scn2’.

thank you.

I haven’t managed it either with the exe file. But an alternative is to download the source and start it via Matlab directly as described in the manual. I was able to run it then but didn’t use it very often.

hello,i have met the same problem.Have you solved it?if did ,can you share the experiencr with us?

for a question ,what application or methods you use to do further analysis,if you will,can you share it with us?

I used the two mentioned here:

1 Like

oh,thank the way,i don’t also find the right way to use the viStaMPS,could you tell me what is wrong.

i used StaMPS 4.1

viStaPS is a miracle to me, sorry :sweat_smile:
Sometimes it worked for me, sometimes it freezes - I have never understood the logic.

Under Windows it worked for me best when I used the matlab-Version, not the compiled exe.

Hi, @ABraun!

It’s me again! I just want to ask if you’ve successfully used and are regularly using viStaMPS?

I am exploring some visualization tools (i.e. StaMPS-Visualizer, viStaMPS) for the StaMPS results.

Fortunately, I managed to successfully used StaMPS-Visualizer. Right now, I am considering viStaMPS but I am getting this error every time I hit the Setup button.

[Error message]

I have followed the instructions from the manual.

  1. Downloaded the viStaMPS full package and extracted viStaMPS.rar inside the StaMPS-4.1-beta matlab folder.

[Extracted viStaMPS files inside StaMPS-4.1-beta matlab folder]

  1. Source StaMPS_CONFIG.bash (as you see from the first screenshot).
  2. I’ve launched matlab and executed viStaMPS.fig.

Any comment will be greatly appreciated.

Thank you.

I think I’ve figured it out.

1 Like

That’s good, because I had no idea :slight_smile:
What was the reason of your error?

hi, could you please tell us how you solved it?

Hi mates, I am using STAMPS to estimate LOS velocity for landsubsidance due to oil extraction, the study area located into two S1A rows but for the same track, track 108 , row 487 and 492 … I have downloaded and processed 86 images for each row, my question is how can I merge the result of the two processed, as I noticed that the overlapped area between the two image gave different LOS for the same point (different up to 6 mm/yr)…thank you in advance

I have solve it, thank you