Step 6 error "changing unwrap_gold_n_win does not work"

Hi all,

I am using 32 SLC and 1 Master for PSI study. I used 25X41 km area approximately (very small area). I used in the mt_prep step mt_prep_gamma_snap 0.4 1 1 50 200.
Then I used stamps then I am giving this following error.Also I found in the forum someone also faced with same error. And he or she fixed it via changing filter window size to less than pixel size. I also tried that but it doesnt work on my process. Could anybody help me? I also tried PSI process before with very big area and I got an error in the step 8 cause of memory. I decreased my area size but not I got an error in step 6. Thanks all.

"Error using uw_grid_wrapped (line 69)
Minimum dimension of the resampled grid (27 pixels) is less than prefilter window size
(20)

Error in uw_3d (line 149)
uw_grid_wrapped(ph,xy,options.grid_size,options.prefilt_win,options.goldfilt_flag,options.lowfilt_flag,options.gold_alpha);

Error in ps_unwrap (line 177)
[ph_uw_some,msd_some]=uw_3d(ph_w(:,unwrap_ifg_index),ps.xy,day,ifgday_ix(unwrap_ifg_index,:),ps.bperp(unwrap_ifg_index),options);

Error in stamps (line 204)
ps_unwrap
"

Did you ever figure out a solution? I’m having a similar same error.
Thank you. (edit: noticed my error similar but not exactly the same)

I changed the size of study area helped to handle this error.
Fikret

1 Like

This problem occurs because using images from the different source (copernicus and asf). I fix this by only use image from copenicus and the process will run smoothly

1 Like

Do you mean add more swaths or subset little bit bigger on the study area?
Thank you

Hi
I mean subset size. You need to use bigger area.
Fikret

@reyhanrere
Have you found Stamps handles a stack created from granules sourced from Copernicus differently than the same stack created from granules sourced from ASF?

@Fikretjfm
What have you found is the min/max size?
The subset I made to test the workflow is about about 360 sq km (12 x 30 km ).

Thanks

My area was almost 30×40 km when i used the last try and no error occurred.

Sorry, I’m back on this. Apparently there is no difference between copernicus and asf

have you ever encountered a problem like this?

@reyhanrere

Yes, that reads similar to the error I’m getting (screenshot below)

Hi all,

Following a computer crash, I had to reconfigure stamps intallation again, on cygwin/Windows, which in that time worked perfectly.

Now, I got exactly the same issue that you say concerning the “Subscript indices must either be real positive integers or logicals.” at Step 6. I’m still investigating where that error comes from, but from now I’m clueless! If I find something I’ll share it obviously.

Hi all,

In my particular case the issue comes from the parameters that have issues and are unstable between folders. For a reason I still do not understand, the points with no coordinates (NaN values) are not deleted. A workaround is to delete manually these values in planty of files, but it is kind of annoying, and I think linked with folders misconnections. But it works, though…

Dear @cfatras
I already solved this problem by change .lat and .lon that generated from TopoPhaseRemoval with .lat and .lon from stack_deburst

1 Like

@reyhanrere: Thank you for sharing your experience. You mean you manually created the lat and lon file based on the stack_deburst product and replaced them in the StaMPS output “geo” folder?
Then you ran the whole process again: mt_prep_gamma, stamps(1,6) ?

@ABraun Yes, that’s exactly what I did
And everything run smoothly :smiley:
I hope it can answer all your questions
Thank you

2 Likes

So they are somehow different?

Edit: I compared and noticed the lines/rows are different. I’ll give it a try.
I created lat/lon bands in band maths and then exported them in Gamma format. I copied the metadata (was only exported once) so now I have

20180101.lat
20180101.lon
20180101.lat.par
20180101.lon.par

Thses four replace the files in the \geo folder and now I run mt_prep_gamma_snap

@ABraun thank you for helping me in explaining it :smiley:
And actually the files that work later are only .lat and .lon
So files with extension .lat.par and .lon.par can be deleted

1 Like

I see, thank you. I thought they would be required. I am currently at stamps(3,3) and will report if the unwrapping now works.

Finished - you rock!
I marked your post as the solution.