Step 6 error "changing unwrap_gold_n_win does not work"

Hello. I’m having the same problem.

How do I create the lat. and lon. file from the bands math? I’m working with COSMO SKyMed products, and I only do the coregistration and interferogram formation for the pre- process.

You need to use bigger size area. Then try again.

I am first time use the SNAP and stamps ,I meet the same error as yours, you say using Band Maths create the lat and lon bands, could you tell me how to do it? thanks you very much.

this is no longer required when you include the generation of the lat/lon and dem bands directly in the interferogram creation operator.

In the interferogram Formation I include the generation lat/lon like this,1.PNG
when I run the stamps(1,8); in MATLAB,I meet this error,

I saw the twburns’ answer about how to sovle this error,
But I am new to PS-INSAR,I don’t know how to use Band Maths to create lat and lon bands ? thanks for your reply.

this is a quite outdated solution and refers to the mt_prep_gamma_snap script which is no longer used.
So if the StaMPS export created the lat lon files and you ran mt_prep_snap successfully, I don’t think it will help to re-create the lat/lon bands manually.

But if you want to give it a try, you can replace the files in the DEM folder as suggested here: How to prepare Sentinel-1 images stack for PSI/SBAS in SNAP (step 9).

I rather suspect that snaphu might not be running correctly. What happens when you type snaphu in the command shell (not in matlab)?

i have the same error in the step 6. But i dont understand why this happend, i already run again all the process and the result is the same. Any idea how to fix this error?

was snaphu installed correctly?

yes, now i can run everything but i have one final problem, StaMPS complete sucesfull but when i call
the first command line ps_plot(‘v-dao’, ‘ts’) appears and error:

StaMPS returned an error “Unable to read file ‘./tca2’: no such file or directory.”
unable to load(apsname).

Days ago i haved the same problem and the solutions was reinstall StaMPS but now isnt work. Maybe i need change the StaMPS folder but i dont know how this can be a solution. i already modified snaphu and triangle folders.

if you haven’t implemented an atmospheric correction, you can only run “v-do”

i run mt_prep_snap and after that stamps (1,8) in matlab like always, default values.
One time ps_plot(‘v-dao’, ‘ts’) works but after that, i ejecute
load parms.mat;
ps_plot(‘v-dao’, -1);

and the same error appears, after that i run again all process and the same error appears for the firs line of code. The only options can modify is the stamps_config.tcsh, but i set the snaphu, triangle and stamps folders in first step.

Please try v-do instead

ps_plot(v-do) and ps_plot(v-do, ts) works fine, thanks. But i dont know why cant apply v-dao. Is a config problem? because if i cant run ps_plot(‘v-dao’, ‘ts’) and ps_plot(‘v-dao’, -1), even if i run stamps(1,8) i supose StaMPS run the entire code. i dont know how can export the files to kml.

Is a config problem? Because sometimes works, what can do to fix it?

in my last work appears in matlab the ph_disp, but in this project i dont see, so im a little lost.

Now works perfect. Thanks a lot, i dont remember when i start that the code is v-do and no v-dao. Im really exited about this topic. THANKS!!


The a in ‘v-dao’ stands for removal of atmospheric impacts. This only works if you cobfigure StaMPS with external tools, this is not done by default.

I do sbas with isce and stamps, what is the sixth step error,I see my Number of points per ifg : 0

@damianvz :hello!,I meet the same problem “Unable to read file ‘./tca2’: no such file or directory.”could you tell me how to solve it?thanks

you can only run v-dao when you have implemented and executed TRAIN in step 8 (it creates the directory). If you don’t have TRAIN, simply plot v-do

Hello @ledi_04,
how did you solve this problem at step 6?
I’m processing CSK.