Supervised Classification Problems on Landsat 8 scene

I’m really having a problem in the supervised classification of one Landsat 8 - OLI scene were I can’t get any results. I’m using for starters de Maximum Likelihood and I’m getting this kind of results:

I did obtained results with the Unsupervised Classification (K-Means):

Even with minimum distance classifier (although very poor results).

Can anyone please, help me solve this problem?

Thank you so much

Did you use pins as training vectors?

Hi Abraun,
No. Only vectors.
Here’s an example:

sorry, I just wanted to go sure because there are pins in the screenshot.

The overlay of vectors and rasters is a bit faulty for some UTM zones. Have you tried projecting the data in WGS84 (import the vectors again afterwards) as described here?


I will recap my steps:
I imported a LS product: LC082040312017110601T1-SC20200511135125.tar.gz (using optical sensors, Landsat, 30m resolution function). Then a subset for the region of interest. After a re-projection to WGS:


Then I did a vector import of ESRI shapefiles (created in the original subset image without reprojection):
image
Then ML classifier and no results again :frowning:

It’s very strange, because to the previous pre-processing actions, the RF Classifier did work (partially I have to say, because is not classifying the water pixel reflectances, at least most of it, only the water breaking zones), take a look:



For the same input the only thing I get is a blank result, in the ML case:

Could this be related to low spectral values of L8 images for the water ? I really don’t understand, because Unsupervised Class did it’s job for the same values(!?). It’s confusing.

strange indeed, but I was able to repdoduce this error.

@marpet Do you have an idea what is wrong?

ABraun,
I edit my previous reply with some additional comment about RF class, that maybe has also something to do with what could be wrong. Please take a look.

I have seen it but do not have an explanation why it worked for RF but not ML.

Hi guys!
Have already anyone found a solution for this error?