Dear, all.

This problem is not about s1tbx but I think that everyone here might know about this.

I have a question about TanDEM-X CoSSC data.

I want to know coregistration information about CoSSC data like which pixel of the slave image correspond to (1,1) pixel of the master image before coregistration.

I want to make coregistration phase but i couldnt find it even i read xml files and DLR documents.

Could you please let me know where can i find it?

Thank you. :slight_smile:

1 Like

Hi, I am new in TanDEM-X CoSSC data. I saw from the website it said we can acquire the data by submitting a General Proposal (there’s no open proposal call available) , but we need to pay 60-100 Euros for each product. Is there a way we can get some data freely for scientific research? Sorry for disturbing and many thanks in advance.

as far as I know you can also apply for a quota from the European Space Agency (ESA) within their Third Party Missions program here.


Thanks a lot for your reply, I will try to apply it. :grinning:

Hello @ABraun

Just want to ask how can I get or calculate the Height of Ambiguity HoA information of my TanDEM-X data. I need such info for the forest height estimation model.

Thank you very much

You can load both images separately (TSX, TDX) unto SNAP and use the InSAR Stack Overview

Thank you for your reply.
I tried using File → Import SAR sensor → TerraSAR-X & TanDEM-X function and I managed to open the files individually. However, after some time I click the File again but the drop-down selection does not appear. Is there might be any problem with my SNAP software?

sounds strange. Do the other menus open?

ya seems no problem with other menus.

No idea, sorry. I expect it to work again after you restart SNAP. Does the InSAR Stack Overview work as expected?

I uninstalled the version i used v.6 then installed the latest v.8 but showing error “Unexpected Exception”. Then I uninstall and re-installed v.6 and managed to import only TDX. When trying import TSX it showing the same error.

Version 6 is unsupported. If you found a bug in 8 it can be fixed.


Thank you for your reply.

I have reinstalled the v.8 and try to load the TDX TSX separately using the import menu.
Still having the same error.

Here is the error detail.

The path looks strange. Can you SHIFT + Right-Click on the file in the Windows Explorer and select “Copy as Path” and post the path here?
It looks like the data is on drive G, but what are the characters before the G.

1 Like

the \G:\001 is suspicious. Is this a server location? Maybe also the path is too long.

Can you please put the folder containing the produc (starting with TDM1_SAR_COS) in a directory with a simple and short path, e.g. C:\Temp\ and test again?

@marpet @ABraun

Yes I resolved the problem. The path was too long after I unzip the original file I didn’t move it to the main folder that was the caused.

Now I managed to load separate TDX, TSX data.

Thank you for your prompt reply.

I really appreciate the help. Have a nice day

The Height of Ambiguity and other info look like this.
I assume it is correct, please let me know if any detail is not. Thank you

1 Like

Looks good! What is your aim with the data?

Thanks. Working on forest height estimation sinc model using the coherence info with height reference data.
@ABraun -Please advise if any suggestions.

I’m no expert here, but the data quality should allow it.