TanDEM-X CoSSC error caused by data format?

Hi all,

I am currently working with TDX data in CoSSC format and I am facing some problems to read them with SNAP. The scenes I have are from 2011 - 2015 whereas two scenes from 2015 aren’t not readable. I got a java.lang.NullPointerException error.


I know there might be a discussion about this issue earlier, but I did a bit try and error e.g. reducing the path etc. without any success. So I compared the scenes which are readable with them who aren’t and I found out that not readable scenes have in total four intensity bands which might cause the error. See the figure below, left isn’t readable and right is readable. Just to prevent misunderstandings, I want to open the TDM file not the single TSX/TDX files.

Maybe someone can help here.

I have the same error,
loading the TDM is not possible beacuse of java.lang.nullpointerexception error, but my TDX/TSX files are looking fine. I can also coregister them in Snap, but I would like to use the already coregistered TDM file.
any help please?

maybe this is related to this error which came with the latest update:

Do you have the chance to test if it persists in an older version?

Well, I think this is another issue.
I’m assuming this, because I have a lot of cossc data and I was able to open just one of them (the others are still not loadable). This one which I could open showed up the error you mentioned as I tryed to use the interferogram formation. But the others are not even loadable and get the java.lang.NullPointerException error as soon as I clicked the open button.

alright, so these issues is not related.

Is the one causing the error of a reasonable file size?

I tried to read the data in an older version of snap, but the error is still the same. So the error is surely not version related.
Your tip with the file size might be reasonable. The files which are readable are not bigger than 5.5 Gb. However the files with a size of over 7 Gb are not readable and causing the error as mentioned above.
Do you have any suggestions how to proceed?

How many bands are contained in the 7 GB dataset? Some of your products are quad-polarized and some are not. Maybe this is part of the problem… Generally, all TDX data should be readable.

Do you have the chance to open it in ERDAS Imagine, for example, just to see if the data is alright?

Yes, both of the >7 Gb datasets are quad-polarized (HH, HV, VH, VV). What means in total 24 bands for these datasets. However, the other datasets are just HH polarized (6 bands). Of course this causes the bigger file size, but is SNAP not able to read quad-polarized TDM data?

I am afraid, but I don’t have the possibility to open the data in ERDAS Imagine. But I am pretty sure that the data is OK.

actually it is able to read it. Which xml are you using? The one in the main folder of the ones of the scenes in the corresponding subfolder?
SNAP cannot open the XML in the top folder, you have to select the XML in the subfolders and stack the two acquisitions.

I would like to open the already coregistred TDM-file. So I try to open the xml in the mainfolder. The ones in the subfolders (TSX and TDX) are readable.

the one in the main folder doesn’t work for me either.

Ok, I guess the error has something to do either with the file size or with the quad-polarization!

To open the TSX- and TDX-XML and do the co-registration myself might be a workaround, but I would like to compare all the TanDEM-X data, I have consistently as possible. However, if some data is co-registered manually and some not wouldn’t satisfy my.

Cheers Bjoern

I can totally understand this :slight_smile:

1 Like

That’s a good question. The xml file I’m loading in SNAP ist just 17 KB, but of course the TDX/TSX data is bigger (2,4 GB each ), the whole TDM folder I get from DLR ist about 5,20 GB each.
I was also checking if the lenght of the path (I’m working on windows but tried also under linux) is to long, but this should be fine.
Also ENVI is able to open all my Cossc TDM data files without any issues but unfortunately I can not use ENVI for further processing. Or is it possible to export the loaded data in ENVI in such a way I can read and process this output in SNAP?

yes, it’s the same with me

Is the data you are trying to read quad-polarized?

First of all thank you for your help!
I was doing the same like in this youtube tutorial: https://www.youtube.com/watch?v=xbIrhbzNrRo&spfreload=1
but yes, my data is quad-pol. Would be bad, if this is cousing all the troubles…

I really appreciate your help too, Anna and Andreas :slight_smile:

Thanks for the tutorial link. There isn’t single-polarized data used. So obviously SNAP is able to handle TDM-XML files with different polarizations.

Maybe @lveci or @junlu can answer the question whether there is any file size or polarization restriction to read TDM XML file with snap?

Regards Bjoern

Hi @bbroschag,

Would you be able to provide a download for the quad-pol data? We are currently working on improving the TSX/TDX readers for the next SNAP release, and need access to some quad-pol TSX/TDX data for testing.