Terrain-Flattening results in garbage when using Copernicus 30m (Auto Download)

I have tested various different DEMs and all work correctly (including SRTM auto download) except for “Copernicus 30m Global DEM (Auto Download)”. The “garbage” results contain zeros in a regular pattern in the Terrain-Flattened product. A very small subset is shown below.
image![image|352x355]
image

The solution I found is to copy the auto downloaded compressed TIFF files to remove the compression. I replace the compressed TIFF files in my local cache directory, and then auto download uses my uncompressed versions and produces a correct result.

This may not be an issue for Windows users since compressed TIFF files have worked elsewhere. Linux users have had to use uncompressed TIFFs (particularly for DEMs).

This is on Linux running SNAP v 8.0.8, using: S1B_IW_GRDH_1SDV_20210211T010234_20210211T010259_025552_030B70_3977_Cal with Copernicus 30m Global DEM (Auto Download)

Thank you for sharing. @jun_lu is this a known behaviour?

We have noticed this problem and are currently working on it. We will keep you updated. Thank you

1 Like

There is a flaw in my tests: I am now not able to reproduce good results with the uncompressed DEMs. Something else I did solved the problem. Back tracking now.

The problem has been solved and the fix should be in the next patch release. Thank you

1 Like

Can the fix be installed manually into an existing SNAP 8 version by downloading some code from Github? If so how? What is the ETA for the next patch release that includes the fix?

If your SNAP is built from source code, then you can simply update the code and build SNAP again. The fix should be there.

I have also same issue any suggestion for this so please reply.

Take the downloaded DEMs in your local SNAP cache …/auxdata/dem/Copernicus 30m Global DEM/ or other DEM, and mosaic them together. You can then use the mosaicked DEM as an external DEM. Remember to select Apply EGM and the DEM file probably cannot be compressed.