"the specified region if not null must intersect with the images bounds" of debursted interferogram

Dear all,
I experience the problem “the specified region if not null must intersect with the images bounds” when the subset is included in the processing graph. I know this has been discussed before, and from my understanding, the most important step is to do the subsetting after the debursting. Yet, I do not get this to work.

The following works (OK):
I have started with the built-in graph “TOPSAR-Coreg interferogram” from the Graphs->Radar->Standard graphs menu. I use the subswath IW2. OK.

Then in-between Deburst and Write I inserted a Subset with either pixels (0 to 100 in X and Y) OR a geographic extent within the IW2 subswath (close to the center). OK.

The following does NOT work:
As soon as I insert anything else after Subset and Write (for example Terrain Correction or a Speckle filter), the graph interrupts with the error “the specified region if not null must intersect with the images bounds”.

I work with SNAP 7.0.0 on Windows 10. The data are Sentinel-1 SLC data (VV and VH channels) from northern Sweden (hence being above 60’N) with an external laser based DEM in GeoTiff format.

Any suggestions on how to overcome this?
Thanks, Henrik


The message refers to an error in the subset step, in other words the subset result is empty, Did you check up the result after subset?

Or the other reason is, the subset in SNAP does extract the AOI and replace the unwanted area with NAN, using graph to subset, I think keep up the NaN area and exclude the AOI.

The solution could be , subset the AOI in SNAP and continue the processing using graph.

1 Like

Thanks for your reply.
The output from subset is not empty - it does actually contain the area I want and I can look at it in SNAP. However, I cannot process it (as a whole or single bands from the product) further in SNAP. If I for example try to apply the speckle filtering on the opened product, SNAP interrupts with the same error message.

However, you triggered some error solving in me… If I compare the latitude and longitude that SNAP shows when hovering the lat-lon raster (tie-point grid) with the actual subsetted data (Intensity, Phase, Coherence …) these do not overlap! It contains the neighboring region. It appears, like the subset function does not cut the same area for the metadata. I guess the SNAP developers have to look at this.
It appears, that the lat-lon rasters are correct, while the coordinates for the actual data (intensity, phase, coh) are incorrect. Is SNAP computing the coordinates that are shown in the lower-right corner, based on some starting position (e.g. top-left pixel) and the pixel size?

1 Like

Let’s solve the problem from scratch,

What kind of product do you use? I guess GRD , sentinel - 1 , IF yes, What are the processes are you following to get the SpickelFiltering result? Or Do you apply other processes? And you you have SLC products!

The subset is done in SNAP! Right ? To be sure you got the AOI!

In general this error, refers to the low amount memory, in this case if your machine has enough RAM, how much is it? And Do you run more than one process simultaneously?

Yes, I had saw similar error and hopefully @marpet has time to have a look at it.

If I correctly got this point using shpfile, in to subset in SNAP , yes, However, in graph using the Polygon I think No, and this is the cause of subset in graph.

1 Like

full process as follows:

Working with SLC data (generating interferogram). I have 64 GB memory and I only run 1 process at the time.
The subset is done in SNAP (however, I don’t use a shapefile for this, but I draw the rectangle myself).

I’d make some comments in your processes,

please apply ESD after Back-Geocoding, also I think there is no reason to apply Speckle- Filtering, multillook step could be good solution also to exclude the speckles from the infgm,

If it’s run so for so good, if not, Please remove the subset from the graph, and re-apply the gpt again.

Please take a look a the following post of Create Single Interferogram

Source of the post

I’d make some comments in your processes, Apply Split operator (In which bursts the AOI) after Read and before Apply orbit,

Do you refer to another Split operator than the one I used (TOPSAR Split)? Otherwise I don’t understand what I should chnage here.

Regarding ESD (Enhanced Spectral Diversity) I have added this with its default settings after the BackGeocoding. I also removed the speckle filtering, since it still did not work (same error as before). However, adding ESD only resulted in the output being NA everywhere. Then I removed the Subsetting as well, and then it ended with another error, “Cannot construct DataBuffer”.

I agree that Speckle filtering may not be necessary, but that was just one simple example that failed due to the subsetting. I want to apply some other additional steps if I get the subset to work.

No, I meant the same but I didn’t recognize it from the my quick first glance, I edited my previous post as well,

Be sure of selecting the same bursts of the IW1-IW3 in each image,

One important point, Which DEM do you select in the step of Back-geocoding? Does this DEM cover the AOI?

Would you please to share the identifier name of both images!

Would you please to use this graph,

CreateSingleInfgm.xml (6.3 KB)

I have used IW2 for both images. They are

I use an external laser based DEM at 10 m resolution that covers IW2. However, I process a coastal region and those parts in the sea are NA values (or not covered). Approximately half of the IW2 image is in the sea.

I edited the previous post and added up the graph of creating single Infgm,

Concerning the both granular, I think there is no problem,


Coming back to the DEM, as you mentioned NaN are already existed, in some parts, but might be reproject the DEM to EPSG:4326 could solve the problem!

I tried your graph, but since it is outside the SRTM area I changed to the ASTER GDEM. Then it stops with the error that “IntegerInterferogram requires two coregistered stacks as input”.
And I already work with the DEM in EPSG:4326, since there was problems with this in the past.

Only the auto download is selectable DEM’s otherwise you should download them,

Do you mean your DEM?

I think there is no problem with projection itself, however the problem is with the DEM SRTM 3sec.

true! I changed to my laser DEM instead (I meant my DEM), but still the “IntegerInterferogram requires two coregistered stacks as input” error. I replaced IntegerInterferogram with the interferogram, and then the graph runs. However, the graph still does not solve my initial problem with using “subset”.

Many thanks though for taking the time and giving valuable input for trying to resolve this.

No problem,

Do you mean the problem is solved (without subset operator)? Or not?

IF not, I could give trial and process them today late in case you’d send me your DEM,

Coming back again to this point, it’s possible to be sure from the granule coordinates by using ,

thanks @falahfakhri for the input about geocoding too!

The problem is still not solved - I claim that there is a bug/problem with the Subset operator. I can still skip the subset and obtain my wanted final result by processing the entire scene, but to improve the processing speed I would like to also use the subset.

I reported about it here since I want to contribute to a better SNAP software and also clarify if I perhaps was using it wrongly.

I think nothing wrong with the use itself, however subset operation within the graph has an error, I mentioned here also, I had the same problem, thus, I excluded the subset op. from the graph and process it separately in SNAP.

1 Like

Debursting works fine without on the original bursts but I wanted to save time and space, I also was trying to exclude huge water bodies before the interferogram creation.
I am getting the same error as well, even though I have saved the subset as (BEAM DIMAP format) file. any solution yet?