Time series tool problem with ROI

I need to calculate the ROI mean value in a polygon for S1 time serie.
With the time series tool in SNAP v6.0 I can see the graph in the cursor mode and for multiple pins, but I can not do the process with ROI.
After I have draw the rectangle and pressed the button for show averaged ROI the graph does not appear.

Thank you,


Did you follow these steps:

Sometimes checking the filter icon or selecting the ROI again is needed for the graph to refesh.
But I recommend using the mouse-over function first to see if it basically works.

thank you @ABraun for your reply,
I have already done, with mouse-over and with pins it works. I tried to manually drawing a rectangular shape and even load a shapefile, but nothing works with ROI.

have you saved your product after digitizing the ROI?

Sometimes you need to close and open it again before the geometry is fully usable.

yes, I have tried but the result is the same. no graph was built.
just to be clear, I have drawn the ROI in 1 single product of the 187 in the product explorer, save it, and closed/open it.

yes, you only digitize it once, but all rasters have to be loaded into the time-series tool.
187 seems quite much to me. Have you tried with 5 products to see if it works? Maybe it just needs too much time to load…

just tried, same problem.
initially seam it works because appear a straight line in the bottom of the graph window but if I wait a few seconds the line disappear. (with 6 products or 187, same behavior)

Hi @nicola.sangiorgi , I have the same problem. Did you manage to get it working in the end?

@ABraun do you have any tips how you should create an ROI? I have tried closing everything, restarting computer, reloading with just 5 products… It still works with the cursor, but does not seem to recognise the polygon.

I cannot reproduce this, sorry.

I just tested with 7 terrain corrected S1 scenes and created a polygon from scratch (in the last product, did not even save it). As soon as I confirm with “Apply” in the time-series tool, the cursor mode becomes active. Then I checked the filter option (nothing to filter here, because each product only contains one band - Sigma_VH) and then switched to the polygon mode. The only thing I can think about is that the polygon must be selected (especially if there are more), at best with the selection tool from the toolbar grafik so that it gets this yellow dashed bounding box .

Edit: Works for me with different vector containers as well:

Multiple polygons per container (same color) did not really work (chart was displayed but not taking values of both polygons).

Hello! I have a problem with the Time series tool. The chart is not displayed correctly for the option Show Average ROI. When I move the click in the ROI the value of NDVI it’a about 0,25, but for the Average ROI it’s about 0,45.
Please help,I need help urgently!
Thank you!