Toolbar issue on MacOS Ventura

Same Issue with Ventura, M1 Pro Chip. Not possible to downgrade for safety reason, trying to install VM on the Mac but due to the Mac architecture only can install linux arm which not support the SNAP version. Hope apple will trying to solve the problem with open GL and Java.

I think the problem is with 3rd party application frameworks that failed to keep up with Apple’s graphics API’s. Apps built using those frameworks were relying on interfaces deprecated years ago and now dropped from Ventura. Many GUI applications, not just ESA SNAP, suffer from this. Apple has a history of such “problems”, but overall many of the deprecated interfaces had weak security, so in general you are better off

There are options to install older macOS versions or linux in a VM if you can tolerate the performance
hit for your use cases. Getting these to work is not assured, and may not be a trivial exercise. ESA plans to fix SNAP, but other use cases rely on software that is no longer maintained, so if you want to try one of the VM approaches you should look for reports for similar efforts to enable legacy apps.
Consider using:

Apple: Running Linux in a Virtual Machine seems to support x86_64 linux.

GetUTM App is based on QEMU and says: lower performance emulation is available to run x86/x64 on Apple Silicon.

I finally ‘solved’ after two days… first cut the folder snap/snap and paste is somewhere else.

then open the app, it will tell that cannot find any module, and ask you either exit or continue without the modules, click the second… then it will show a naked NetBeans window, close it. Then paste back again the folder snap. The app will open, the menu toolbar will work but before getting excited you should go to tools in the menu bar, then plugins, and then activate again the plugins of S1, S2… otherwise you wouldn’t be able to open any file. Besides, install again all the other plugins, close the app, and bingo!


Interesting. Have you tried this with Apple Silicon? Is there an explanation for why this works? Does it
hold up over reboots and updates or do you have to do this every time you use SNAP?

1 Like

Strange. I am on an M1 Max with Ventura 13.0.1. I followed the steps as follows:

  1. Copy the folder in /Applications/snap/snap to another location
  2. Delete /Applications/snap/snap
  3. Run /Applications/snap/bin/ application
  4. Disable modules and continue (as prompted by NB)
  5. Close the NetBeans window that opens
  6. Place copy of snap folder back in original location

This did not seem to work, so I tried again.

  1. Delete /Applications/snap/snap
  2. Run /Applications/snap/bin/
  3. Now NetBeans notices missing plugins and asks if it can install
  4. Proceed with installation
  5. Restart SNAP as prompted by NetBeans

Then, the toolbar and everything appears to work. Good idea! Maybe overtime there will be an answer for @gnwii. For now I will leave my installation as is. SNAP runs when I tried to open a few more times without needing to repeat the process. The only difference in the program is a NetBeans splash loader shows as SNAP loads rather than the original SNAP splash loader.


Like jfe I have a Mac M1 with Ventura 13.1.1 and so far it is working good, I just needed to those steps once… (well… to find those steps that’s another thing hahaha) just as an update I didn’t delete anything, I just cut the snap/snap folder and place it somewhere else, I run the app, it got me this warning, I pushed continue, and then I put back the folder and I run the app again. The final step is activate and install the plugins.

You are a genius. Thank you so much. You let me to work again without getting crazy to find a computer on which preprocess satellite data.

SNAP support should hire you ahahah

Thank you again.



Does someone have an idea why this works?
Actually, the configuration is the same as before these steps.

I am running on an “Apple M1 Max”, 64GB, macOS Ventura 13.3.1 (22E261). My initial install (fresh + updates) of the ESA SNAP tool fails to show either tools and/or “Open Product”.

I followed the “delete snap/snap folder, restart, …” discussed above and got to a point where I could see both tools and “Open Product” windows. However, when I tried to actually load a Sentinel-2 image, it failed (likely a separate thread to discuss that). Further, when I re-installed the Sentinel-1 Toolbox I lost the ability to see the tools and “Open Product” windows again.

I have not seen any other post discussing if this might be a problem with just the Sentinel-1 Toolbox.

Hi all,

I had the same issue with snap GUI being unresponsive. I have Ventura 13.3.1 and M2. I fixed it using josbel96’s genius method.

Thanks a lot!

1 Like

Did you try josbel96’s method twice? I had to repeat it when I noticed things not working (for a total of three times).

I’m experiencing the same problem with the Mac Ventura M1-pro processor. In the image, you can see that the “open product” option is not appearing.

Thank a lot Josbel, This works as you said. Will start processing some data to see how it works in the long run.

Thanks again!

Thanks to @jfe and @josbel96 for the workaround. It solved the problem for me on MacOS Ventura + Intel MacBookPro 2019.

Thanks to @josbel96 for providing this method, it did work.

@marpet, I did some tests and I seem to found something.

The problem may be caused by “World view” and “Product library” components.

I notice that when I use josbel96’s method, the tool in the windows will be removed because of disable almost all plugin of SNAP. When I use “Windows->Reset Windows” to reset the toolbox in SNAP, the problem will occur again. So I try every component one by one and finally find that when one of these two components enable, the menu will not show anymore. If I remove it and restart SNAP, everything will be fine again. I suggest that it could be the 3D render part of Java have some problem with the new version of macOS.

This above is my speculation, maybe someone can verify if it is true or not, thank you.

1 Like

Thanks for the report.

we have also solved it for the next release. So it will be no issue anymore in the future.


When are you going to release version 10? Is there any penciled date?

Tentatively mid-August.


Hi! You are a genius. I did it and it works correctly. but now I have another problem. I don’t know if this problem has something to do with the procedure.
now in my menu File > Import > SAR Sensors, I only see two of all the sensors supported by the software.

Could you please give a help?



Hello! Thank you for yogur solution.

I dos your procedure and it works perfectly.

But now in my menu: File > Import > SAR Sensors > Does not appear all of the sensors supported.

For example SAOCOM

It will be because of that procedure

Could you please give a hand?