Unable to initialize WWWorldMapToolView: XXX0 profile[1]: GL3bc -> profileImpl GL4bc ! not mapped


I am getting the following error while lunching the SNAP application. I installed the application today in my Ubuntu 16.04 LTS.

Unable to initialize WWWorldMapToolView: XXX0 profile[1]: GL3bc -> profileImpl GL4bc !!! not mapped

What is the solution?

Thanks and Regards,

I had a case once where SNAP didn’t start properly, but when the internet connection was disabled before/during the start, the problem was somehow solved.
Once it its started, you can change the standard basemap in the settings.

Maybe these two posts can help you.

Dear ABraun,
This did not worked for me.

Dear Marpet,
Presently I am using the following method suggested by you.

Select General /World View and mark “Use flat Earth projection”
Also you can close the “World View” window. Instead you can open the “World Map” from View/Tool Windows.

The error is still showing during every startup. But, I think this error is not a big issue??


It is just annoying for you. Maybe you try to update driver of the graphics card. This should help permanently.

I have updated the graphics driver on Ubuntu and such error doesn’t pop up anymore, however the world view window doesn’t show anything as if there’s no image loaded in tye product explorer whatsoever. It appears white blank window.

WorldView downloads data on demand, so there can be issues with internet connectivity and delays before the world map appears. You should see differences in the messages.log files after updating your driver.

The internet connectivity is working fine and I have updated the graphics driver to the nvidia-driver-390 (proprietary, tested) and the error message that used to appear before, doesn’t show up now but still there’s no world view after loading the images

If you mentioned your SNAP version, I missed it. There has been considerable churn of space agency URL’s. There are also problems with denial-of-service (DOS) attack countermeasures blocking legitimate users.

Posting the most recent “messages.log” with details of your OS a and driver versions may allow someone with a matching configuration compare messages relating to WorldView. In the past, I have installed a NOAA WorldWinds standalone app to debug problems. The NOAA site has useful documentation for working around problems.

I am new to Linux OS, I cannot find the installation path for the program therefore I am unable to get the “messages.log” nor am I able to re-install the program. Any suggestions, please?

The Help menu has an entry to show the location of the logs. Please don’t reinstall before collecting details of the problem. Reinstall rarely solves problems in linux (unlike Windows), only delays proper

messages.log (42.3 KB)
messages.log.1 (43.6 KB)
messages.log.2 (43.7 KB)

Here are the message log files. I am using those versions of Ubuntu and Python

And Snap version

I’m also getting the ‘unable to initialise WWWorldMapToolView’ error, on a brand new install of ubuntu 22.04.1 LTS. Can’t seem to update the graphics driver , but it shuold be bang up to date as the install is only a few weeks old!
my system is old, but does everything else ok! :
messages.log.1 (81.8 KB)
messages.log (186.4 KB)
hardinfo_report.html (37.7 KB)

Eventually the problem has been solved after numerous updates carried out through Ubuntu’s software Updater and a restart. Maybe the graphics driver needed an even later update cuz the one I had chosen earlier may have been out-dated. Yet I do appreciate your concern. Thanks a lot for your time

Your logs have the error discussed in the previous thread for SNAP 8: https://forum.step.esa.int/t/snap-8-0-javax-media-opengl-glexception/31893, which ended without a report of success or failure. The WorldMap requires OpenGL. Problems with OpenGL are not unusual due to buggy drivers and lack of a mechanism to tell users which linux packages they need.