Workflow between SNAP and StaMPS

yes script is in.
mt_prep_snap MasterImage RouteToMyStampsExport/ 0.4 1 1 50 200
Like This:
mt_prep_snap 20200326 /media/sadi/WORKDIR/INSAR_20200326/ 0.4 1 1 50 200

sorry, I was browsing the forum on my phone and confused your issue with this one. Obviously, all scripts run fine on your side.
As your error occurs during step 4, there could be something wrong with the unwrapping.
Maybe this solution is an option: It requires to compile snaphu on your own (instead of apt-get), so first removing the existing instance is required. I cannot guarantee if this will solve your problem (although the error message is quite similar), but if you are familiar with compiling scripts, it could be worth a try.

Thank you so much, Sir! I just try maybe it works. I will come back to you soon hopefully with some positive response. :slightly_smiling_face:

1 Like

Installing 3rd party packages with “sudo” may result in user configuration data being owned by “root” and/or being stored in root’s home directory. Complex packages often lag behind changes in the OS or have only been tested in one OS, so may overwrite critical OS programs.

Using the whereis command explains why you had a man page in one of your environment variables. Also, your X_BIN variables sometimes refer to the bin directory where a program can be found and sometimes give the full path of the program. The documentation always shows the path to the bin directory where the program has been installed.

Is there a guide/tutorial of SNAP-to-StaMPS worflow, for time series creation? It would be much appreciated

yes, please have a look at this post: StaMPS - Detailed instructions

1 Like

Hi Gijs,

Could you resolve this issue? I’m having the same problem…


Check this below one, For me it’s working.

1 Like

Thanks a lot suribabu! but unfortunately that didn’t work for me…
Apparently, not so many people had the same issue so probably that’s something related to the dataset.

hey, i ran into the same problem. have you found the solution?

i’m getting this error in mt_prep_snap, pls help

Remove inverted commas and run

The space in a directory name likely causes your problem.

1 Like

instead of INSAR_20160219 just give INSAR_20160219/

i tried with both suggestions, it worked but another error came
is it my system? i downloaded ubuntu in virtualbox and set up everything for stamps

The “segmentation fault (core dumped)” error occurs because StaMPS was compiled with the wrong compiler. You find a solution here: Segmentation Fault (core dumped) error during mt_prep_snap - #17 by ABraun

1 Like

In my case this error was caused by failing to start a new project with a fresh INSAR_XXXXXXXX directory. Solved by clearing old files from the directory then rerunning mt_prep_snap.

Hello Everyone,

I have a simple question regarding geocoding process.
In SNAP-StaMPS processing steps, in which step the geocoding is done?
I have checked one of xxxxx.rslc.par file in PSINSAR_20180425/rslc folder, it says “image_geometry: SLANT_RANGE”.
It means that the image is still in range and azimuth (radar coordinate) after “”.
However, in matlab, when I run "ps_plot ‘u’ " after step-6 (StaMPS) the unwrapped phases is already in longitude and latitude coordinate.
So, is anyone know in which step the geocoding was done?
Thank you.

the variables are explained in the script

1 Like