Workflow between SNAP and StaMPS


I have some updates. Stamps export finally worked! There were a few reasons for stamps to not work:

  1. When we create lat long bands, we need to convert them. Right click > convert. Then only the bands will save.
  2. Names of bands should be ‘orthorectifiedLat’ and ‘orthorectifiedLon’. I was using capital O instead of small O and Long instead of Lon.

Thank you for all the help! I believe that Stamps should run smoothly from now on.

1 Like

great that you found out. Converting the virtual bands to physical ones is probably important. THanks for pointing it out and good luck for the further processing!


@ABraun :excuse me, do the enviroment of snap2stamps package run ?
More question:where did you download snap for linux ,I find it only for windows and nuix,Can you tell me.?

I think this will help.


Stamps worked properly upto step 7! But the images were somehow incomplete so I am now trying to process the subset instead of two whole swaths. However, when I created the subsets and then tried Stamps export, I get this error (Image attached). Does subsetting removes the geocoding and other necessary information? Can you please help me?

Also, I noticed that something might be wrong with the stack itself (Before interferogram and dinsar). When I tried to create subsets, I am getting this image in the subset window. It seems that stack is itself incomplete and therefore, stamps processing is also incomplete. Images are attached for subsets of both stacks (before and after interferogram). I tried to merge that stack many times just to make sure. Can you please help me in that too?

Thank you!

Image of error in Stamps export:

Subset interface with stack before interferogram:

Subset interface for stack after interferogram:

P.S. - I hope that all of you are safe from Corona virus. Take care.

snap2stamps requires python, please check the official manual:

1 Like

if you use the same stack for the interefrogram generation, they should be of equal dimension. Applying a subset afterwards will probably only make it worse.

What indicated that the images were incomplete? If you made it to step 7, the problem should be elsewere (and not coming from the dimensions).

Nothing indicated that images were incomplete, but when I got the results after step 7, I saw that the IW3 subswath had not been considered, even when I had merged IW3 and IW2.

Should I apply merge and subset before computing interferograms then? Will that work?

I dont know, sorry. Give it a try!

Merge should be done after deburst (as indicated in the standard graph provided within SNAP) but individual IW interferograms should be ok, so I suggest you test individual IW interferograms before merging.

This will be included in next snap2stamps release

Yes, but my question is “If subsetting after interferogram causes dimension loss, should I merge and subset both subswaths before interferogram?”

Because interferograms stack is looking good even after merging both subswaths. It is the stack with ESD only that does not look good. I am trying to do this method right now: Stack>ESD>Deburst>Merge>Subset>Interferogram>further processing. I do hope that this will work.

Subsetting should be done after Merging.

Split-Coreg-Ifg per each IWs, later Merge and finally subset.
Interferogram is done at IW level. Please check the TOPSAR Coreg Inteferogram IW All Swaths provided in SNAP

BackGeocoding > ESD> Interferogram> Deburst> Merge> Subset and further


thanks a lot .I’v follow the step by install snap6( reference: in ubuntu18,after finished installtion ,nothing appeard,even with ‘snap or sudo snap’ in command line in ‘/snap/bin’ directory,also python 2.7 is installed, Help me please


here is the information below:
y@sentinel:~/snap/bin$ snap
The snap command lets you install, configure, refresh and remove snaps.
Snaps are packages that work across many different Linux distributions,
enabling secure delivery and operation of the latest apps and utilities.

Usage: snap […]

Commands can be classified as follows:

     Basics: find, info, install, list, remove
    ...more: refresh, revert, switch, disable, enable
    History: changes, tasks, abort, watch
    Daemons: services, start, stop, restart, logs
   Commands: alias, aliases, unalias, prefer

Configuration: get, set, unset, wait
Account: login, logout, whoami
Permissions: connections, interface, connect, disconnect
Snapshots: saved, save, check-snapshot, restore, forget
Other: version, warnings, okay, ack, known, model, create-cohort
Development: run, pack, try, download, prepare-image

For more information about a command, run 'snap help '.
For a short summary of all commands, run ‘snap help --all’.

I had used the same workflow before but when I did subset, stamps export is giving me this error (image attached). that’s why I was looking for new workflow. Also, from what I understand from this answer, if I do subset after interferogram, stamps export may not work.

Can you help me please? Is my understanding wrong?

This might be useful. I think everyone in this forum were having the same problem as you.

You should apply the exactly subset for both stack of corregistered master slave amplitude and stack of interfergram. It is obvious but maybe you did forgot about it.

You need to merge and subset also de corregistered amplitudes.

I believe the issue is here rather than were to change the subset operator.

Let us know

your system knows another command “snap” which is executed when you type it in.

Do you find the installed version in your menu?

Otherwise you have to run the snap inside the bin by typing ./snap

my OS is ubuntu, no start menu, yours seem like Kubuntu? :grinning:
yes, after I ran it inside the bin ty typing ./ started with starting logo for instant,then I configured it with python ,It started well,thank you very much.

Hi all,

Stamps export worked perfectly after I did this:

split>Orbit>Stack>Deb>Merge>Subset>ESD>Interferogram>Further process.

So, basically forming the interferogram after subsetting works perfectly!

Now, I have these results (Image attached). Now, what can I do next? How can I convert phase to displacement? Any further processing should be done here?

very good, thanks for reporting the solution.

You can plot “v-d” or (if you removed orbital ramps) “v-do” to get the displacement values instead of radians.