C2RCC problem for S2-MSI

Hello everyone,

I am using the C2RCC operator in the last SNAP 6 release (beta 5) on Sentinel-2 MSI products to monitor river color.
After resampling the Sentinel-2 MSI product to 10 m with the resampling operator, I have run the C2RCC operator for S2-MSI sensor.

I got a strange result using many different observation for the same granule (T32TQQ). Specifically, the ‘Chl’ and ‘TSM’ concentrations (and also other reflectance bands) resulting from the operator have the same (wrong) estimated value for the first 5000 columns of pixels. In some cases also for the first 500 rows of pixels.
I attach a image showing the result.

This happens also if I generate a subset from the granule and also if I export the resampled and subsetted product before running the C2RCC operator. Even if after the resampling they are less than 5000 columns in the entire image, the problem occurs at the same geographical location. It seems that this behaviuor affects only the products where the Sentinel-2 detector footprints do not cover the entire granule (with the Sentinel-2 swath limited to one part of the granule).
I have checked the Quality Flag of the input S2 L1C product and the resulting C2RCC product without finding any flag layer masking the affected areas. I also tried to change the tile dimension to ‘11000’ in order to try to avoid the tiling of the Sentinel-2 image.
In order to help the developers solving the problem, one of the images affected by this problem is:


  • Can be this problem only related with Sentienel-2 products with footprints not covering the entire granule?

  • Is this problem related to a NN training done only on one subset of the granule?

Hope this may help to find a solution.


Maybe this is caused by the view geometry. Zenith and azimuth are given in a very coarse resolution.
When resampled to a higher resolution they need be treated special.
Try the S2 Resampling Processor which is located in Optical / Geometric. Maybe the results are better.

I cannot find the S2 Resampling Processor in SNAP6 (preview 5) nor in SNAP5.
I also tryed to look at gpt available operators and at the graph builder, and tried to deactive and reactivate the S2 toolbox kit module under plugins.
Where do I find the operator?


Have you tried the search field at the right top? Is it available in the graph builder?

Sorry Federico, it is not yet available in the preview 5.
You can either try the internal RC1 or you wait until Monday.
Then the final SNAP 6 version should be out.

I can wait until monday.
I am just wondering if the new release will try to solve in some way the issue reported here to delete the cache files only at the end of each gpt execution (or when exiting snap application), instead of at the start up, in order to let the users execute more than one (simultaneous) gpt call at a time using Sentinel-2 images as input.

Thanks for the support!


The issue is marked as resolved. But I don’t know what was done and if it was solved in the way you would like it.
@obarrilero Can you say something about it?

Hi Federico,

the issue solved was deleting the cache since it was deleting nothing before.
About your problem, I think it will continue after the release. I am going to create another issue in our issue tracker to improve this, but for the moment the solution is to select another “cache policy”.

The use of the S2 Resampling Processor solve the problem. It effectively resample the S2 sun and view geometries in more effective way, with a smooth spatial gradient.

The following WARNING is reported from gpt when calling the ‘S2Resampling’ operator:

SEVERE: org.esa.s2tbx.dataio.jp2.internal.JP2TileOpImage:

It is printed only for some Sentinel-2 L1C products (the product reported in this topic is affected) and the process take a longer time to execute (1140 seconds VS 95 seconds), and printed about 20000 times for a single scene processing . Anyway, the resampled product does not seem to have any problem, but maybe this should be further investigated.

Thanks @marpet @ABraun @obarrilero for the support.


In the image it is possible to see the differences for the view geometries and sun angles layers when using the resampling processor and the S2 Resampling Processor introduced in SNAP 6.

1 Like

for use in snappy see Generate view angles from metadata Sentinel-2

Something related to S2 but not solely for C2RCC is that by using other plugin for downscaling of 20-60m bands to 10m (i use the Sen2Res - https://step.esa.int/main/third-party-plugins-2/sen2res/ - which is damn good for b1 (https://www.sciencedirect.com/science/article/pii/S0303243418311656)), i cannot use the output to the C2RCC for further work. Seems that is related to the new created .xml on metadata… Have you seen similar behaviors?