Conc_chl.img Band missing after running C2RCC on MSI


After running C2RCC on MSI scenece, I dont see conc_chl.img band in folder to see chl concentration of pixels in python. However, it can been seen in SNAP.


Please take a look at the section 5.4 C2RCC Processor to be sure that your processing was correctly implemented,

Source :

Also take a look at the following post,

Source of the post

Did you search the STEP FORUM, I found also many topic related to your issue,

Yes it is correctly implemented.

The Conc_Chl is a virtual band. This means it is computed on the fly in SNAP when you open it.
The data is based on the iop_apig and the chl_fak and chl_exp parameters.
By default the expression is: pow(iop_apig, 1.04) * 21.0
When you right-click on the band and select Properties from the context menu you can see and edit the expression.
If you want to have it as a physical band on disk you can export it to e.g. GeoTiff or NetCDF. Or you use the band math, create a new band and use the band name ‘conc_chl’ as expression. Make sure that you uncheck the virtual option in the Band Math dialog.

Actually, @ABraun showed an simpler way of converting it into a real band:

1 Like

I tried this bit it dowsnt work.
gpt BandMaths S2A_MSIL1C_20170412T110621_N0204_R137_T32WPV_20170412T110619_s2resampled_C2RCC.dim

For BandMath you need to provide a Graph XML file which defines the configuration.
Try gpt bandmaths -h
Then a template is printed to the console.

This is how i run it
for folder in $(ls -d S2*.dim); do gpt chl.xml -t S2_Data_C2RCC_CHL/$folder -f BEAM-DIMAP $folder; done

    <node id="ch conc">

And what is the error you are getting?

There is no error but the final image is blue.