Error in creating L2A User Product

Hello guys,

I have some problems with the Sen2Cor Plugin version 6.0.2. I wanr to correct this product: S2B_MSIL1C_20180520T141049_N0206_R110_T20JNM_20180520T173536.SAFE with the Sen2Cor-plugin. I’m not sure if I must select the L2A_GIPP file in the processing parameters, but it doesn’t matter. Everytime I want to run the plugin this message appears:Error_Sen2Cor
What’s the error? I don’t understand it.

Thanks for help!

Perhaps your input product is missing some files. Have you downloaded it from https://scihub.copernicus.eu ? Are you having problems only with this product?
There are some similar errors reported and solved in the forum. Please see for example:
Error in creating L2A User Product (sen2cor 2.3)

No I downloaded it from Earth Explorer, should I try it with files downloaded from scihub?
Thank you, I’ll take a look at the other topic.

Some times the products downloaded from other sources are not exactly in the format expected by Sen2Cor. If possible, you could test with one from scihub to confirm that your installation is ok.

I try it with other product and it runs. But now, if I want to open the MTD_MSIL2A xml file in SNAP this error appears:
Unable to get metadata from JP2 images associated to product [MTD_MSIL2A.xml]

Please help :frowning:

could it be that your path names are too long. Try placing the whole product under C:\Temp\ for example and see if the error persists.

Proposed solutions for this error:

I’ve had the same problem with files downloaded from schihub. So far i have only been able to successfully run sen2cor on one product from 2018. are there any other solutions to this?

I’ve set up a pipeline on AWS to run these through. I’d be happy to give it a shot with any you’re having trouble with. See if I can duplicate the error at least…

Thanks but i finally got it to work. I’m also going to try to use RUS which shouldn’t have these bugs…i hope

Hi, I have the same issue with an S2 product. How did you manage to solve it?