Error Topographic Phase Remove


#1

Hi, when I delete the topographic phase, I get an image of purple. Tried to use different DEM, SRTM, GMTED, ASTGTM2, GT30. Because of what there can be an error?


#2

it is purple in areas where no DEM could be found. Did you chose the ones with the (Automatic Download) option in the dropdown menu? If yes - is your data located outside the SRTM coverage?

Image source


#3

I use automatic download, but I downloaded the SRTM to the desired territory and put it in the “auxdata” folder. That’s what I get when removing a phase, is this true?


#4

doesn’t look right.
Should work with the automatic download. If you manually download DEM files there are many error sources like file name, folder structure and data format.


#5

I have a similar error, like Anton_ Gorshkov, when i doing TopoPhaseRemoval processing I get a purple image.
What am I doing:

  1. I downloaded 2 SRTM files to my territory, srtm_63_03.tif and srtm_63_04.tif (downloaded from here SRTM);
  2. Merge them in a mosaic (in QGIS);
  3. Filled empty holes with the help gdal_fillnodata.py;
  4. Save to the folder /home/%user%/.snap/auxdata/dem/SRTM 3Sec /srtm_63_03.tif.
  5. Create Graph and in it:
    <node id="TopoPhaseRemoval">
    __<operator>TopoPhaseRemoval</operator>
    __<sources>
    ____<sourceProduct refid="Read"/>
    __</sources>
    __<parameters class="com.bc.ceres.binding.dom.XppDomElement">
    ____<orbitDegree>3</orbitDegree>
    ____<externalDEMFile>/home/%user%/.snap/auxdata/dem/SRTM 3Sec/srtm_63_03.tif</externalDEMFile>
    ____<externalDEMNoDataValue>0.0</externalDEMNoDataValue>
    ____<tileExtensionPercent>100</tileExtensionPercent>
    ____<topoPhaseBandName>topo_phase</topoPhaseBandName>
    __</parameters>
    </node>

In Logs i get errors:
SEVERE: org.esa.snap.core.dataio.ProductIO: Error attempting to read home/%user%/.snap/auxdata/dem/SRTM 3Sec/srtm_63_03.tif with plugin reader org.esa.s2tbx.dataio.s2.ortho.plugins.Sentinel2L1CProduct_Multi_UTM55S_ReaderPlugIn@1fe8f5e8: The product /home/%user%/projects/home/%user%/.snap/auxdata/dem/SRTM 3Sec/srtm_63_03.tif was not parsed or does not contain any granule

Tell me please how to correctly use external DEM, in what folder to save, in what format?
P.S. My Dem territory and data…


#6

Unfortunately I do not have internet access, so I can not load DEM automatically. If I download DEM and put in the folder “auxdata” because of this, it may not be correct to delete the phase?


#7

I only know that there are naming conventions for the DEM placed inside the aux folder but I don’t know the exact requirements.

There are other topics dealing with this issue but it wasn’t clearly sovled yet:






#8

Thank you)


#9

Dear ABraun, I tried to remove the phase by automatically loading the SRTM from the Internet and I get the same result. Can such be that SRTM it is constructed not correctly? This is what SRTM looks like when I open it in SNAP. Territory Kurile Islands.


#10

this means there is water outside the white are? Maybe then the colour stretching of your image is just not set correctly due to outliers?
Can you show us a screenshot of the colour manipulation tab?


#11

White is an island, Black is water. Screenshot of the colour manipulation tab


#12

-32768 is a so called NoData value. It’s the smallest value a dataset of signed integer type can store. Just move the black triangle to the right or click the 95% button and you will see more shades of grey.

This was caused because no elevation information is available outside the land area, but only -32768 (=no data). When SNAP simulates topographic phase based on the DEM, these areas result in wrong phase estimations. Therefore it cannot be subtracted from the interferogram correctly.


#13

When I moved the black triangle, my remote phase turned out like this. I have a displacement map like this. How are you?


#14

looks better!
You can now try different image pairs and see if they produce similar patterns. Sometimes atmospherical disturbances interfere with the signal.


#15

Thanks for the help! I understand correctly, where the negative values are there subsidence of the earth’s surface?


#16

theoretically yes. But some of them might also be just caused by noise in the signal. So if you want to go sure, just analyze a different image pair and compare if the subsidence occurs at the same locations.


#17

Here I have a question about the explanation of displacement. What does this displacement stand for if there is no water vapor effect?

Since an early version of DEM was used, does the result stand for displacement from Sentinel observation date T1 to Sentinel observation date T2? The phase removal from the early version of DEM may not remove DEM phase on Sentinel observation date T1 . I think we have this common problem when using SRTM data which was collected about 17 years ago.

Or some displacement related to error of DEM was also included? How to evaluate which one is the primary contribution to the final displacement results? Any suggestions?

Additionally question is also about DINSAR, will the result reverse if I reverse the sequence of master and slave image of Sentinel-1 IW SLC data? What is the correct sequence? I usually saw the master image was observed earlier than the slave image.

Any reply is highly welcomed.


#18

Hello, XianWei. According to my understanding of two-pass DinSAR(since you mentioned DEM, it should not be 3- or 4-pass DinSAR):

  1. the displacement is the change of slant range from first/master acquisition sensor position in each pixel between T1 and T2.
  2. DEM error either from difference acquisition time (such as SRTM in 2000 and Sentinel in 2017) or other reasons, also contribute to differentiate phase, just like displacement such as seismic activity or glacier flow. However, attention should be paid to their sensitivity. Please refer to <雷达干涉测量-廖明生林珲-测绘出版社>page 136 and 137. The sensitivity of phase difference to displacement is 4pi / wavelength, while the sensitivity of phase difference to DEM error is 4pibaselinecos(theta - alpha) / range / sin(theta), which means phase difference is much much more sensitive than DEM error because range is much much longer than baseline. Therefore, the differentiate phase is primarily caused by displacement.
  3. theoretically speaking, if the baseline is very short, the result would also reverse after exchanging master and slave image. In practice, taking baseline effect and stochastic noise into consideration, they cannot be exact opposite number, but should be positive and negative value with magnitude of same order I guess.
    Sorry for ugly mathematical notation.
    师兄好,抛砖引玉哈

#19



an example from Prof Xiao Cheng’s Doctoral thesis.


#20

Thanks for your reply.