Installation error on SNAP-5.0 on window-x64

Dear Sir:
I have an question on installing the SNAP on windows 10. The installing Error is like this:
instll4j Wizard
ESA SNAP is preparing the install4j Wizard which will guide you through the rest of the setup process.
install4j Wizard
The installation file is corrupted .If it is a download please try it again.

I have already installed install4j and add environment variable in path.But the problem is still existed.
I eagerly hope to get an answer to solve this problem.

Best Wishes

are you sure that you downloaded the full installtion file?
Did you run the installation file with administrator rights?

I download an complete .exe file, file name is “esa_snap_sentinel_windows-x64_5_0.exe”. I want to know is the installing process need high speed networks? I have tried to install SNAP on two computers and had the same errors. The first one didn’t have network, the second one have network but the speed is very low. Is that matter?

once you downloaded the file, you no longer need network for the installation process.
Is your file 441 MB large?

No , It is 401487KB, 392MB. This is very strange. I download in chrome and chrome told me download is completed. I download twice and get the same large file. Sir, do you know why is that?

which one did you select?

I choose the first one . Sentinel Toolboxes Window 64-bit. Oh may be we use different operating system.So the the volume of the file is different.

then it’s possible. I chose ‘All Toolboxes’ and it’s a bit larger.
Despite of that I would try to re-download it since it is stated in the error message that some parts are missing. Or you can try the ‘All Toolboxes’ instead.

The esa-snap_sentinel_windows-x64_5_0.exe installation file should have a size of 401MB. Please try again to download the file.
may be with a different browser.

Yes, I should try to download the ‘All Toolboxes’ .Thank you very much.

Sir, thank you. I will give a try later.

I am sorry, Sir. I have a question while installing SNAP. The error appears when the installing process was close to finish. It says ‘… couldn’t create file …’ like this picture below. I have ask my friends and they said they don’t know what can cause this. Could you help me?? Thanks in advanced

ps: My C: Drive isn’t full yet

This thread is for a different problem with a very old version of SNAP that is no longer supported.

Please read the FAQ.

You should look at other reports of the same error. If that does not solve your problem, please start a new thread and include details of your OS version and SNAP version you are trying to install.