New StaMPS release (4.1-beta)

You can either do that, or try to merge them without lossing anything important in between.
Personally, I would suggested to swap between them, yes.

I hope that this would solve your problem. Let’s see

ps_plot(‘o’,1) AND, ps_plot(‘o’), they work fine within the new version, the only thing I didn’t do last time was, after rerun step 6 after step 7 (Unwrapping step); set_parm(‘scla_deramp’,‘y’), scla_deramp should set to ‘y’ then run step 7 again for spatial correlated look angle error, and then ps_plot(‘o’) run fine, this is the results,

1 Like

Can i install StaMPS in ubuntu server 16.04 ?

Yes you can! And also in 18.04

Please can i know how to use train ? I changed the paramaters of subtr_tropo to ‘y’ and let the tropo_method as ‘a_l’ and reruned the step 6 and when i continue and run after this step 7 i have an error message. I also tried scla_reset but nothing have changed.
Thank you for you time.

1 Like

I personally intend to add the TRAIN, but to be honest I didn’t apply it before, however here in the following posts you could find more discussions about this matter,

Source of the post

and this post,

Source of the post

I suggest in this case to rerun the normal stamps, steps without any change, if this technically goes normally without any error, then, I’d suggest to change the parameters,

Here you could find good example it helps too much,


Thank you, I want to do the atmospheric correction do you know a simple way to do it ?

Take a look also at the following post,

Source of the post

Read carefully the posts I shared with you, then you’ll find that the AC, is inclusively done throughout stamps(8,8) .

it request scla2 probably right?
first have to run aps_linear in matlab then!
did you source the train config file before starting matlab in the terminal?

just type aps_linear in the matlab console.
More information is in the TRAIN manual.
The aps_linear should work with only TRAIN installed and sourced, no additional packages.

please the path of aps_toolbox that i have to edit is the path to the train folder that i have in usr/local/ no?

yeah, just the main train folder!

It doesn’t work for me, i have no error but i get empty plots (with one color)

Hi, do you have one for Small_baselines, sb_load_initial_gamma.m?
I have the following error when I used the current sb one after it calculates the baselines for each of the interferograms, I think it is trying to sort local coordinates?

READPARM: initial_baseline_rate:=0.0000000 -0.1139888 -0.0192730
Index in position 1 exceeds array bounds (must not exceed 2).

Error in sb_load_initial_gamma (line 146)
bl=mean(sort_x(1:n_pc,:)); % bottom left corner

Error in stamps (line 221)
** sb_load_initial_gamma;**

1 Like

How are you?
First of all, thank you very much for dedicating so much to the stamps so that we can all work with them today.
I’m processing Sentinel 1 images, and I’ve done, I guess, all the steps before exporting to stamps correctly.
After running the mt_prep_snap routine without problems, I execute the steps of stamps (from 1 to 8) without problems, however when visualizing the results I find that the first 6 interferograms look good and the remaining ones present failures. It seems that the values are “out of order” or something like that.

If we look at the interferograms (.diff) in snap, for example 6 (02032017) and 7 (04042017) , we see that apparently there is no problem, however in the graph of w (above) the first one has been imported to the stamps correctly and the second one has not.

When obtaining the average speed graph (v-do), the result seems quite consistent, which also calls my attention.

I have exported the data to stamps again from snap, and run mt_prep_snap again, and I still have the same problem. I have checked every file in the geo, diff, dem and rslc folder. I’m using 35 patches, with an ad of 0.4. I don’t know at this moment what could be the source of the error, any idea?
Thank you very much.

Interesting case, I have never seen such an error. The only thing which sounds a bit odd to me is the 35 patches. Whatever you enter at the end of mt_prep_snap should result in an even number of patches. e.g. ...2 3 results in 6 patches. 35 sounds way too high to me, especially with an overlap of 50 to 200 pixels, as suggested in the manual. Could be the reason for the strange pattern, but does not explain why it does not affect the first few.

1 Like

Hi, @ABraun
I never thought about the number of patches as a problem with this.
I already tried it with 6, 15 and 20 patches, and the problem is still there.
In all cases, I get almost the same number of PS candidates.

Please try to make the plot ps_plot(‘u-dmo’,1), I would like to see if there is anything on the scripts… as the ps_plot(‘v-do’,1) looks fine to me.

Hello, @mdelgado
Sorry for the delay.
Here is the result for the u-dmo with 35 patches.

The process with 6 patches gave the same results.
I’d rule out that the number of patches is the problem.

One thing that strikes me is that in the center of the deformation observed in the first ifgs, there is a lake (black dots) and that remains in all ifgs.

This could be due a non-PS on those positions. Hence, no data, black or white depending on the background color selected.

Here the strange effect on the lines seems not be present or not that strong. Do you agree?