New StaMPS release (4.1-beta)

I think stamps cannot handle the (n:1) you used. Try
or simply

Hi Andy,

I’m sorry, it seems I didn’t posted well, I meant with ‘n’ in previous post as number, I don’t use it in this way, As it is clear in the manual, I highlighted with yellow color, to drop any of unwanted ifgm, apply this function, but it doesn’t work and gives error, I also applied


It runs fine, but didn’t remove any infgm, I also tried the following


It doesn’t remove any infgm


can you please post a link to the manual of version 4.1?

StaMPS_Manual_v4.1b1.pdf (1.5 MB)

shouldn’t it be this one then?

You will then have to run stamps from step 3 again.

I don’t think,

First of all the goal of the step I want to apply is, Exclude the infgms, those they are not well unwrapped, then I think this is other issue, since it is clear in the manual as I posted before and here below again and highlighted the STEP 7,

In my opinion, instead of dropping interferograms, I would apply the ramp estimation to remove the ramps/trend and not the interferogram itself, as you got many interferograms with ramps, so your final analysis will have only few interferograms left.

Keep it simple. Once you know better how to use the different options, increase the level…
That is my advice, you can always take it or not. Until now they brought you to a good point.

1 Like

Off course your advice and opinion are important for me,

I’ll give a try , I’ll check up the manual, How to to do so!

I really appreciate your support Jose,

Apart of that , I think ’ scla_d ’ has error.

1 Like

Had you tried the setparm(‘scla_deramp’,‘y’) as mentioned?

Yes, It works fine as I mentioned in previous post, but would you please to give some tips concerning the ramps estimation and removing. IsIt should be applied after step 7?
And then 're apply step6?

This is done during step 7.
After running step 7, you always should re-run step 6 (whatever option had scla_deramp), or at least is what I have always understood

Could you please plot the ps_plot(‘u-dmo’,1) and share it here?

1 Like

Sure, I’ll run step 6, after 7, and share it

I re-run step 6, Unwrapping, below is the results of ps_plot(‘u-dm’), it is obvious the ramps in many infgms,

and following is the ps_plot(‘u-dmo’,1),

Would you please to explain more, how we could get better results?

I like more this latest results, as now are not ramps there anymore. You could see what you have removed using the command ps_plot(‘o’,1) .

Answering to your question, well, you could try to use TRAIN, the toolbox for atmospheric noise removal developed by David Bekaert, and there you can use weather models, and other data to reduce the APS of the scene.

In fact, the trends you have removed using the ‘o’ option, other people say that are tropospheric ramps, and not orbit ramps, so you could also use this toolbox to help you removing noise.

Additionally, you could use GPS data or similar to reduce bias and fit your output to that, but it is something more difficult that one forum thread can handle.

Still, I invite you to look for this techniques in literature and see what you could think to use/apply.

Another option is to use the step 8 integrated in StaMPS, which does a spatio-temporal filtering to estimate APS signal. Then, for removing it the option is ‘s’ (from slaves) and should be used as follows: ps_plot(‘u-dmos’,1) but I cannot recall if this option is not supported. Just check it out


Tremendous thanks to you, but do you recommend to proceed with these results?

Or to get continue with your very nice suggestion!

As the manual instructions is followed,

Run both ps_plot(‘o’) or/and ps_plot(‘o’,1) gives the below error,

1 Like

Had you defined any reference point?

Manually I didn’t define, but as you see the 2451646 ref ps selected automatically.

It means that it takes all available points. I am not sure why you got the error…

May you try to manually define one?

Yes, It is possible, how to define, might be I didn’t read all the manual, or I didn’t see anything related to define rp manually, would you please refer to it,

for example:

setparm(‘ref_cen’,[lon lat])

where lon lat are the longitude and latitude coordinates of the point used as reference area with radius 100m

Please check that could be [lat lon] instead of [lon lat][ as I might be mistaken