No Valid Orbit File Found. Download Orbit Files

Hello,

I downloaded an SLC S1B file for March 31st, 2021 from the ASF Data Search Vertex site https://search.asf.alaska.edu/#/?zoom=3.000&center=-97.494,39.673. I brought it into SNAP to run S1 TOPS coregistration on it iwith another file from February 2021. When I add the March 31st file to the “Read(2)” tab I get the below error message:


I tried going to the mentioned website https://qc.sentinel1.eo.esa.int/ but the site could not be reached. I searched in the Step Forum for similar problems, looks like most of the time this was an issue of the data file being less than 21 days old, but it is June now so the file is at least 2 months passed processing by now.
I did find this website from another discussion https://scihub.copernicus.eu/news/News00323 which lead me to https://scihub.copernicus.eu/gnss/#/home, where it looks like I can download orbit files. I found an orbit file from S1B under the product type AUX_POEORB that matched my files date of march 31st, 2021
image

I followed SNAP’s error instruction of placing it in the following path under my username
.snap\auxdata\Orbits\Sentinel-1\POEORB\S1B\2021\03
then closed out of SNAP, reopened it, tried to run the coregistration again but got the same error message.

Is there a step I am missing in this process?

I realized my second picture is of the wrong file but I did download the 3/31/2021 file. But I do see there are three different dates to a single file:
image
I assume the first date is what needs to match, correct? Or do I need to match one of the other dates?

Just wanted to say I have been having this problem too. Did you find a solution?

Facing same problem. any solution

Thanks in advance

Hi there,

Yes, I did solve this but what I found is depending on the date, an orbit file might not be available as of yet. Go to the below website and download the orbit files for the satellite and desired orbit dates:
https://scihub.copernicus.eu/gnss/#/home
The long file name has several dates, sometimes they’re the sensing date, sometimes they’re not. On the download wizard just look for the date below the download file
image
Then once downloaded save them on your local drive in a folder path similar to the below path:
C:\Users\(your name)\.snap\auxdata\Orbits\Sentinel-1\POEORB
Satellite folders are split by S1A and B, then split by year, then split by numeric month (January = 01, August = 08, etc). Save the orbit file in the proper folder path, restart SNAP, and that should do the trick.

1 Like

I did the same. But im still getting the same error

my dataset are as below
S1B_IW_SLC__1SDV_20210709T020700_20210709T020727_027711_034E98_6670
S1B_IW_SLC__1SDV_20210709T020725_20210709T020752_027711_034E98_4519

Hi Dev,

Unfortunately I’m still new to SNAP, so if you’re still having issues I am unsure what else you could try. There are lots of other users in this forum though with far more experience with this than myself, if you start your own post in the forum with the above issues I’m sure someone else might have an idea. Good luck!

Either that orbit file has not been placed in the repository for some reason, or SNAP cannot access it. BTW the quality of the RESORB is already extremely good - have you tried downloading them instead as they are available in NRT and many recent products already have them in the original metadata?

That is so nice of you. I appreciate it. And thank you for the response, and look forward with your suggestion

Thank you Marcus. I will try what you have said

Hi,

@Dev, have you solved the problem, because I am in same situation like you.

kind regards,
Karlmarx Thangamani.

But in this error, particularly it is mentioned for ‘C:\Users(your name).snap\auxdata\Orbits\Sentinel-1\POEORB’ file path. So, how can we solve this?

may I know in which file format have you saved the external orbit file?

Hi Karlmarx, when you download an orbit file from the below website, there’s only 1 file format: .EOF

https://scihub.copernicus.eu/gnss/#/home

1 Like

Thank you. May I know which version of Snap are you using to solve the orbit file application? So that I can switch the snap to corresponding version.

One should always use the latest fully updated SNAP-version, otherwise you’ll miss out on bugfixes and new functionality…

Hello,

I also meet the same problem although I manually downloaded and copied the orbit file to the folder as @cjfergus guided.
Is there any other solution?
Best regard,
Hung

Hi hungbui,

Have you fixed the problem with orbit file?

Greetings,
Karlmarx

Use the latest fully updated version please.

Hi,

Actually, the orbit file application is working fine for me after downloading the orbit file from the link https://scihub.copernicus.eu/gnss/#/home. I just want to say that the downloaded file can be in .zip format/ non zip format and/or also it is not only depending on date (as @cjfergus mentioned) but also depending on time.For example: image. In this case, the previous day orbit file is worked for me as you can see the validity period here in this image


and not the same day (14.08.2021) check the validity period

So I think we should also consider the time along with the date for this problem.

Greetings,
Karlmarx