Opening landsat 8 image

HI, me again!
I am now trying, and failing to open Landsat 8 images.
I have downloaded a product from the USGS explorer:

and unpacked the .tar file as i can’t open that folder (it gives a ‘No appropriate product reader found’ error)
I also tried created a .zip folder from the unpacked .tar, but this will not open either, whereas a downloaded folder will open.
When trying to open the products in the unpacked folder i am offered the following files:
but dont have an option to open the RGB image?
I would like to process this data to give me either an NDVI or LAI dataset for the image, but don’t see band 8 (for NDVI band maths?

edit: I have also tried and failed to open any of the MTL files, and using >import>optical>Landsat>** doesn’t seem to work either!

This is from Collection2, right?
Unfortunately, the Collection 2 is not yet supported.

Well that would explain it!
I take it collection 1 is supported?

Yes, they are readable, but some features are not yet supported.

That’s a bugger, I was hoping to be able to use Landsat and sentinel together to produce a better time series of LAI or NDVI variations in my ROI :frowning:

You can calculate LAI and NDVI on Landsat data from Collection 1.

As long as there is a decent image with no cloud!

May have made a booboo there, do you mean landsat8 collection 1?

yes, I mean Landsat8 Collection 1

I’m still haviung trouble opening the Landsat images. the only way i can do it is to open each band individually. Is there a step I am missing?

actually it should work with File > Import > Optical Sensors > Landsat > Landsat 8 30m > Select MTL file

This opens all tiffs as a stack including correct metadata


For some reason it doesn’t!

as you caqn see, the files are there, but SNAP doesn’t seem to see them.
I did manage to open the product by using >open product and opening the .xml file, which gave me all the bands, so i could then process and subset :slight_smile:
I have been talking to @oana_hogoiu, there were some issues with updates, I did a clean install and found that SNAP was performing better

Where is your data from? In your screenshot I am missing the annotated text files, especially MTL.txt

The import worked in my case with data downloaded from the USGS Earth Explorer which is provided like this

Thats what’s confusing me too! In the screenshot i have my windows file manager and the SNAP import product window open to the same folder.
the data is downloaded from the USGS Earth explorer, Landsat collection 1 and as you can see, I have the files there.
when i use >open product it shows the files:

but as in my previous screenshot when i use >import…>landsat8 30m theey’re not!

@ABraun I’ve tried downloading again from the USGS earth explorer, but I never get the MTL.txt file.
Am I selecting the right collection?
I check the box labelled Landsat 8 OLI/TIRS C1 Level2

I downloaded last week a couple of Landsat 8 L2 without any problems. They can be read in SNAP (collection 1). Maybe you should check in the USGS help or Forum.

@abruescas did you get 11 or 14 files when you unpacked it?

There are 11 files. TIR data are nor included in L2, only reflectances.

Do you have the MTL.txt file?