Problems with opening Landsat data

I’ve got a proplem opening the Landsat 8 data in Snap.
I tried to drag and drop the file into to product explorer, but it always says ‘No appropriate product reader found’.

I am thankful for any help! :slight_smile:

have you tried File > Import > Optical Sensors > Landsat > Landsat 8 30m > select the file that ends which _MTL.txt

Yes, I tried that, but then I can only see the radiance bands.

are you sure you downloaded the reflectance product?

I downloaded the Level-1 GeoTIFF Data Product from Earth Explorer…

aren’t these provided as radiance?

The landsat data provides both radiance and reflectance. By default SNAP reads the radiance.

You can set the -Ds3tbx.landsat.readAs=reflectance property in the file to switch to reflectance.
See also this post.

This refers to Landsat 8 but it is the same for Landsat 7

1 Like

I have SNAP 8.0 - but Landsat does not appear in the sensor list of Import > Optical Sensors ?

Isn’t that a bit clunky way to select a band?

It is not just selecting a band. It selecting how the raw data shall be converted. The are different factors stored in the Landsat data and by specifying the property one can select which are applied.
But yes, that’s not a good solution. But it has historic reasons. Probably today this could be done differently.

1 Like