Replace metadata


#1

Hi. I am trying to apply metadata of Sentinel-1 SLC data to polsarpro outputs using SNAP 2.0.
I used SNAP 2.0 to do these steps : split/orbit/calibration/deburst.
Then I exported the debursted result into Polsarpro format.
I used PolSARpro for some processing.
I’d like to apply the metadata of the debursted data to the polsarpro outputs. Data is same size.
I am able to import polsarpro data into SNAP, but when I try Tools/Metadata/Replace Metadata, it closes the polsarpro data without any replacement.
I used to do that with radarsat-2 data using S1TBX and worked fine.
Any help ?


Calibration in PolSARpro problem
#2

It should work that way. Let me have a look.


#3

dear @lveci ,
have you found the solution regarding to this problem?

same issue also happened to me.
I’m working with ALOS-2 data using the latest update of SNAP 2.0 and Polsarpro.
I want to terrain correct Polsarpro products on SNAP.
firstly I multilook the original ALOS-2 on SNAP and saved it as beam-dimap format, then I imported the polsarpro product (T3).
but when I tried to replace the metadata with multilook file, the same problem also occurs. T3 always closes and its metadata doesn’t change

any suggestion? any help would be very appreciated.

Thanks in advance


#4

Multilooking changes the size of the rasters. Make sure you multilooked with complex output and when you replace the metadata it needs to be the metadata from the multilooked product and not the original ALOS product because its size would be different.

Also, you can create T3 matrices using SNAP.


#5

Thanks so much for your response, lveci.

I’ve done everything according to your instruction, included multilooking with complex output and replacing metadata with multilooked file. But when I started the process, it seems like no processing and the polsarpro product just disappeared (closed).

I also tested the same process using ALOS 1 data, but the result just same. It is strange because I could replace it well using the previous version of this software (using NEST). Unfortunately it doesn’t support ALOS 2 data.

Could you please check this tool again? Thanks in advance

and sorry for my bad english


#6

Dear all,

I am experiencing the same problem.

I processed in SNAP a pair of images (stack) and I made the deburst of the product.
Then I exported the debursted product and I made some preocssing in PolSARpro and also with my own routines.
My final product is a binary file with the same size (same number of lines and samples per line) of the debursted product.

Then I imported the product in SNAP and tried to replace its metadata with the ones of the debirsted stack, but my product disappears…

I would like to make this to use afterwards the terrain correction routines (for geocoding). Is there any way to make this?

Alternatively, is it possible to add a band to an existing prduct, provided it has the same size?

Thanks in advance


#7

You can use the Band Maths (in the Raster Menu) to copy one band to another product. But you need to make sure that you disable the Virtual option. When they have the same size it should work.


#8

Thanks. It works fine!


#9

Hi, I am also facing the same problem with the SNAP version 4. I generated C2 matrix and other parameters from TerraSAR-X dual polarimetric data using PolSARpro. After importing this into SNAP I want to just replace meta data from multilooked terraSAR-X product of SNAP tool box to this C2 matrix. While doing this process C2 matrix closed automatically?

Please fix this problem as sson as possible

Thanks and regards
Surendar


#11

A post was split to a new topic: Polsarpro data not supported anymore?