SEN2COR tool

I have a problem with install Sen2cor. I can not open in command line to type “python install”
I downloaded sen2cor-2.3.1 and Anaconda for Window 32 bit. Isn’t sen2cor-2.3.1 compatible with Window 32 bit ?
I want to try sen2cor-2.3.0 but I can not download it.

Thank you in advance

Do you receive an error message?

No error messages. The problem is when I click on setup file of sen2cor 2.3.1 to open it in command line. It opened so quickly and disappeared then. I tried many times but the same state. I do not understand what happens with it.

Don’t double-click it. Open the shell window in this folder and enter the command manually.

Thank you Abraun,
I set up Sen2cor already.
However, I got problem when I use sen2cor in the first time.
I don’t know how to set “Python_bin” in “Tool Executable” and SEN2COR_HOME"in “Working directory”
I am new with SNAP. Please, tell me if you understand my problem
Thank your very much again.

please have a look at this post:

Dear ABraun,
I do steps as you told, but no screen appear after I typed “Modify environment variables”.
I use Window 7, 32 bit.
By the way, please tell me how to set up “SEN2COR_HOME”. I tried to set in D:, but there is a warning “The variable SEN2COR_HOME has no value set”.
Can you explain it to me ?
Thank you.

actually, the variable can be set in SNAP under Tools > Manage External Tools > sen2cor > Edit

The correct folder is in your user directory > documents > sen2cor. It is created there by the installer. A folder called cfg with a file L2A_GIPP.xml should be inside of it.

Good explanations:

Hello everyone,
I got problem as run sen2cor .
I set SEN2COR_HOME and SEN2COR_BIN in the same path. And result showed the error like this

I don’t know what is mistake.

Besides, when I type “L2A_process --Help” in command line. It also showed some file could not be loaded.

Please, tell me how to solve it
Thanks very much

Is your operating system 32 or 64 bit?

Which version of SNAP did you install - 32 or 64 bit?
Which version of Python/Anaconda did you install - 32 or 64 bit?

my operation system is 32 bit
and I installed SNAP and Anaconda with 32 bit

64 bit of Python is required, as stated in the release note:


You mean that Sen2cor 2.3.1 is not compatible with my platform 32 bit ?
If so, what should I do then if I want to use SNAP

As I am not a developer I can’t tell you exactly, sorry. Maybe you better ask them instead.

Anyways, thank you very much

I think there never was a 32bit version of sen2cor. But @umwilm can correct me.
Best would be to update your system.
A 32Bit system can not manage more than 4GB of RAM. And this is often not sufficient for processing S2 data.

I got 8GB memory with WIN 7. you mean I need to update to WIN 8 ?
I don’t know why, but I can’t update it to WIN8 .
What should I do now ?

please see this article here:

Thank you very much

I keep getting this error in spite of reading through the threads in this forum and following the instructions, any specific mistake I might be doing I am not sure. Please help.
Thank you.