SEN2COR tool


#163

this error message indicates that you renamed the folder with the Sentinel-2 files in it.
The name should stay as extracted.


#164

No I didn’t change anything…


#165

What was your input directory? It looks like you stored your L1C Product on the desktop and that you used C:/…/Desktop as input instead of C:/…/Desktop/S2A_…_L1C.SAFE


#166

yes, I change the directory . But I still have this warning message::
C:\Users\ASUS\Anaconda2\lib\site-packages\glymur\config.py:171:
UserWarning: Neither the openjp2 nor the openjpeg library could be loaded.


#167

In addition, anyone noticed the var/cache folder containing the sen2cor toolbox: its size is 33Gb! Is this normal? I am not sure whether this is the result of running the tool several times. And how the cache works. Can I simply delete it?
It will certainly result in memory problems soon.
I´m just diving into directories automatically created from the snappy-conf and python, anaconda and other required packages for the tool to work. It´s quite hard to follow for non-developers


#168

Hi,help please !At start up se2cor produces such an error. What to do?


#169

I suggest that Sen2Cor and Sen2three would be builtin and provided with SNAP instead of installing them later on independently. Both would be integral part of it. As such, these are inevitable to proceed with the data prior to utilize them in intended applications.


#170

although I would be happy about this, it is rather unlikely to happen because they are developed by two completely different companies so this is (besides the technical aspect) also a legal issue.


#171

There might be legal implications but technically it can be materialized. The implications can be removed legally as well. This will help to mitigate problems facing by all potential users including me:-)


#173

Your suggestion is good and I would support this too. But this can’t happen in the short term.
Both tool were developed as stand-alone tool and we provided the adapters to make them usable in SNAP. This should have ease the usage even though there are problems to be solved. Beside the legal issues, they are solvable, cause at the end it is all ESA, there are also technically issues. Both tools, Sen2Cor and Sen2Three, need to be changed to work within SNAP. Probably also some changes to SNAP need to be done. All this need to be coordinated and some one (ESA?) needs to pay for it.
So, you see, it is not for the short term. But maybe we can start to push the right buttons.

Anyway, thanks for sharing your suggestion.


#174

Yes, there are implications but end user will benefit if these are solved. I am very much eager to see these plugins available in the upcoming SNAP versions. The Sentinels are providing wealth of information to all of us which is appreciable. The efforts aimed to provided these functionalities will help users to harness these datasets without multi tasking.

I still hope ESA will ponder over this suggestion in the best interest of the user community.

Thank you marpet.


#175

My Sen2Cor doesn’t work


And I can’t reinstall gdal

Please, help me to solve my problem.


#176

I’ve managed to make Sen2Cor works.


The link above helped me.
I had to install proper GDAL version, python binaries, and set up environment variables.


#177

I have a problem with install Sen2cor. I can not open setup.py in command line to type “python setup.py install”
I downloaded sen2cor-2.3.1 and Anaconda for Window 32 bit. Isn’t sen2cor-2.3.1 compatible with Window 32 bit ?
I want to try sen2cor-2.3.0 but I can not download it.

Thank you in advance


#178

Do you receive an error message?


#179

No error messages. The problem is when I click on setup file of sen2cor 2.3.1 to open it in command line. It opened so quickly and disappeared then. I tried many times but the same state. I do not understand what happens with it.


#180

Don’t double-click it. Open the shell window in this folder and enter the command manually.


#181

Thank you Abraun,
I set up Sen2cor already.
However, I got problem when I use sen2cor in the first time.
I don’t know how to set “Python_bin” in “Tool Executable” and SEN2COR_HOME"in “Working directory”
I am new with SNAP. Please, tell me if you understand my problem
Thank your very much again.


#182

please have a look at this post:


#183

Dear ABraun,
I do steps as you told, but no screen appear after I typed “Modify environment variables”.
I use Window 7, 32 bit.
By the way, please tell me how to set up “SEN2COR_HOME”. I tried to set in D:, but there is a warning “The variable SEN2COR_HOME has no value set”.
Can you explain it to me ?
Thank you.