SEN2COR tool


#184

actually, the variable can be set in SNAP under Tools > Manage External Tools > sen2cor > Edit

The correct folder is in your user directory > documents > sen2cor. It is created there by the installer. A folder called cfg with a file L2A_GIPP.xml should be inside of it.

Good explanations:


#185

Hello everyone,
I got problem as run sen2cor .
I set SEN2COR_HOME and SEN2COR_BIN in the same path. And result showed the error like this

.
I don’t know what is mistake.

Besides, when I type “L2A_process --Help” in command line. It also showed some file could not be loaded.

Please, tell me how to solve it
Thanks very much


#186

Is your operating system 32 or 64 bit?

Which version of SNAP did you install - 32 or 64 bit?
Which version of Python/Anaconda did you install - 32 or 64 bit?


#187

my operation system is 32 bit
and I installed SNAP and Anaconda with 32 bit


#188

64 bit of Python is required, as stated in the release note:

Source:


#189

You mean that Sen2cor 2.3.1 is not compatible with my platform 32 bit ?
If so, what should I do then if I want to use SNAP


#190

As I am not a developer I can’t tell you exactly, sorry. Maybe you better ask them instead.


#191

Anyways, thank you very much


#192

I think there never was a 32bit version of sen2cor. But @umwilm can correct me.
Best would be to update your system.
A 32Bit system can not manage more than 4GB of RAM. And this is often not sufficient for processing S2 data.


My snap always point out error about java
#193

I got 8GB memory with WIN 7. you mean I need to update to WIN 8 ?
I don’t know why, but I can’t update it to WIN8 .
What should I do now ?


#194

please see this article here:


#195

Thank you very much


#197

Hi,
I keep getting this error in spite of reading through the threads in this forum and following the instructions, any specific mistake I might be doing I am not sure. Please help.
Thank you.


#198

please have a look at this post. It describes how you can tell SNAP where your python installation is loacted:


#199

Thanks for your reply. I tried to install the Anaconda2 and Sen2Cor 2.3.1 but after installation is complete I checked the DOS prompt for Conda and it run perfect but when I tried to run L2A_Process --help I got this error. How can I make a successful installation of Sen2Cor2.3.1? Please advice.


#200

gdal is actually installed with Anaconda. Do you have other python installations on your system?


#201

Yes i found another Python27 folder in C directory that was installed with ArcGIS 10.5.


#202

only the Anaconda installation should be present in your sytem’s PATH variable.

What happens if you just type python in your command line?
The anaconda python should be called instead of the ArcMap one. If the latter is the case, remove the entry of ArcMap python from your PATH.


#203

This is how it looks in my laptop


#204

the one that matters is Path under System variables. If ArcMap is among that, there could be interference of both python installations.