SEN2COR tool

I think there never was a 32bit version of sen2cor. But @umwilm can correct me.
Best would be to update your system.
A 32Bit system can not manage more than 4GB of RAM. And this is often not sufficient for processing S2 data.

I got 8GB memory with WIN 7. you mean I need to update to WIN 8 ?
I don’t know why, but I can’t update it to WIN8 .
What should I do now ?

please see this article here:

Thank you very much

I keep getting this error in spite of reading through the threads in this forum and following the instructions, any specific mistake I might be doing I am not sure. Please help.
Thank you.

please have a look at this post. It describes how you can tell SNAP where your python installation is loacted:

Thanks for your reply. I tried to install the Anaconda2 and Sen2Cor 2.3.1 but after installation is complete I checked the DOS prompt for Conda and it run perfect but when I tried to run L2A_Process --help I got this error. How can I make a successful installation of Sen2Cor2.3.1? Please advice.

gdal is actually installed with Anaconda. Do you have other python installations on your system?

Yes i found another Python27 folder in C directory that was installed with ArcGIS 10.5.

only the Anaconda installation should be present in your sytem’s PATH variable.

What happens if you just type python in your command line?
The anaconda python should be called instead of the ArcMap one. If the latter is the case, remove the entry of ArcMap python from your PATH.

This is how it looks in my laptop

the one that matters is Path under System variables. If ArcMap is among that, there could be interference of both python installations.

and when i type Python in cmd, i get this

that’s good on the one hand because sen2cor uses the correct python version,
but bad on the other hand becuase it doesn’t find gdal.

A solution was proposed here:

hello,I want to ask a question.when I use the sen2cor. It shows:

I want to ask what I should do? where is wrong? thank you!

please have a look at these topics:

thank you for your reply. these question is about 64 bit python, but The python in my computer is 64 bit. I also found this problem.So I just want to ask what I should do? thank you!

according to your screenshot, everything works fine.

Saludos para todos.
Me aparece lo siguiente al ejecutar sen2cor

Process exited with value 2
Finished tool execution in 0 seconds.


I would appreciate any clarification or assistance.

Saludos para todos.

please enter “Finished tool execution in 0 seconds.” in the search field and you will find lots of topics with helpful posts.