SNAP - StaMPS Workflow Documentation

please execute stamps(1,1) and so on from the top folder, not inside PATCH_1

Thank you sir it works but unfortunately I am facing other problem when it runs at step 2 Stamp(2,2)

please just read the error message.


Plus, as mentioned above, please note that Matlab is in fact proprietary software. You need to have a license for add-on toolboxes.

Thanks a lot @ABraun for the answer.
It would appear that it does not affect the final result.
Another question.
How can I visually recognize Unwrapping errors?
I know that I have to use ps_plot_(‘usb’), but what exactly should I look for? can you give me an example or recommend a manual where it explains well what an Unwrapping error is?
thanks a lot

this is hard to see for PS because we don’t see the fringes in the interferogram as clearly as in tradtitional DInSAR approaches, because the PS are connected by a network.

Here is an example where the unwrapping produced errors (phase jumps): Basic Subsidence Formation

These are not as clearly visible for PS, but you can plot all interfefrograms and check if there are patterns in single ifgs which are not contained in others. This can also be due to atmospheric disturbance, but still considered a potential error.

@ABraun You are to kind to everybody trying to get started here, a real hero!

I second your point that he best way to start is just to read through all information sources noted in the StaMPS - Detailled instructions thread.

If anyone has questions about my documentation the best way to contact me is via email, I no longer do InSAR things because I finished my thesis but am still happy to help.

Best regards,


thank you for your kind message - happy to hear that. I see that the materials you and Matthias provided were really filling a gap, so I’m convinced that they already helped hundreds of people.

1 Like

really I dont’ know where is the fault, I did the change you gave me (A Braun) )but the problem is still remain . yesterday I processed my data in snap one more time i did a new export from snap to stamps but the same problem.
i hope that you can see what i can not see. thank you a lot.

Its sad that my thesis was never published then there was a possible reference for it, now i just see it as help and dont know how people would be able to reference an unpublished thesis.

Happy that it helped so many people!

is it an option to put it on ResearchGate or Zenodo, for example, so it gets an own DOI and is officially citable?

1 Like

did you see this post? Segmentation Fault (core dumped)

I’d like to add kudos to @thho here as well. Thorsten’s notes were really helpful for me, too, and most of my guides is based - among others - on elaborations by Thorsten.

Personally, I think that both the topic of PSI/SBAS and the software implementation are quite difficult to get into due to the obvious complexity of what is going on there. To be honest I struggled quite a bit when starting out with StaMPS, even more so since I have no background in microwave remote sensing.

I can only advise everybody to not let yourself get dragged down if things don’t work out of the box. Read the official documentation as well the material provided in this forum as well as in the StaMPS/MTI Google Group. Try to understand what the single processing steps do, and how the workflow works. If you run into problems, please remember to ask concise questions (I really like to reference the Stack Overflow Guide: How do I ask a good question? in that matter). There are really helpful guys here in the forums (most notably @ABraun), but please do not overstrain their willingness to help.


And I fully second that suggestions, both options are viable.

Hi @Naima you need to provide the full path to the INSAR_20200107_data. I have had this error too and using full path has solved it. Note that you should also start the command in that folder, so I would advise to use first:
cd /your/path/INSAR_20200107_data
and then run the command:
mt_snap_prep 20200107 /your/path/INSAR_20200107_data 0.4 3 2 50 200

In linux you can save typing using the $PWD variable:

$ cd /your/path/INSAR_20200107_data
$ mt_snap_prep 20200107 /your/path/INSAR_20200107_data 0.4 3 2 50 200


$ mt_snap_prep 20200107 "$PWD/INSAR_20200107_data" 0.4 3 2 50 200

(quotes added in case /your/path has spaces).


thank you for suggestion, I did but the problem is still. You can see it below.

the version of my gcc is 9.3.0(ubuntu 20.04). I installed gcc 7 and the problem is still. I sourced stamps_config.bash and also stamps_config.tcsh. I ran mt_prep_snap in both shell but the same problem. you can see it below.

after installing gcc 7, you have to install StaMPS again (at best remove it entirely) so it will be compiled with gcc 7 from the beginning.

Dear all, would anyone have any suggestion about the error I reported above?
I would be really very gratefull for any ideas…