Snap2stamps error

Hi,mdelgado, i have a new problem when coregistration and interferogram, before i process this step, i have prepared corresponding DEM in the ‘’.snap/auxdata/dem’’, but when i process this step, it always reloads the corresponding DEM automatically. I’ve never had this problem before. Is there any solutions?Thank you!

Not sure what you are trying… if you include an external DEM, you may need to tune the corresponding graphs to get it directly, as there is no option from the project.conf in the current release.

Thank you for you reply, i solve it!

1 Like


I encounter the same problem as you, how did you solve it?


I have this error while processing, i recently formatted my computer and tried to install snap, stamps, snapp2stamps for processing the data. But i am not sure they are installed properly or not. Can someone please help me in checking the installations?

I can provide access to my computer to check the installations.

Thank you all

Try to change




in coreg_ifg_computation.xml file

This option is changed to two attributes in range and azimute for snap V.7

1 Like

Next release will be compatible with v7

1 Like

in case this is still an issue, just found out that snap7.0 had changed or replaced the parameter " useSuppliedShifts" in operator " SpectralDiversityOp" into two new parameters: “useSuppliedAzimuthShift” and “useSuppliedRangeShift”.

  1. <version>1.0</version>
  2. <node id="someNodeId">
  3.   <operator>Enhanced-Spectral-Diversity</operator>
  4.   <sources>
  5.     <source>${source}</source>
  6.   </sources>
  7.   <parameters>
  8.     <fineWinWidthStr>string</fineWinWidthStr>
  9.     <fineWinHeightStr>string</fineWinHeightStr>
  10.     <fineWinAccAzimuth>string</fineWinAccAzimuth>
  11.     <fineWinAccRange>string</fineWinAccRange>
  12.     <fineWinOversampling>string</fineWinOversampling>
  13.     <xCorrThreshold>double</xCorrThreshold>
  14.     <cohThreshold>double</cohThreshold>
  15.     <numBlocksPerOverlap>int</numBlocksPerOverlap>
  16.     <**useSuppliedRangeShift**>boolean</useSuppliedRangeShift>
  17.     <overallRangeShift>double</overallRangeShift>
  18.     <**useSuppliedAzimuthShift**>boolean</useSuppliedAzimuthShift>
  19.     <overallAzimuthShift>double</overallAzimuthShift>
  20.   </parameters>
  21. </node>

so, if you use snap2stamps scrips in snap7, you have to change the parameter names in graph “coreg_ifg_computation_subset.xml” in section:

  1. <operator>Enhanced-Spectral-Diversity</operator>
  2. <sources>
  3.   <sourceProduct refid="Back-Geocoding"/>
  4. </sources>
  5. <parameters class="com.bc.ceres.binding.dom.XppDomElement">
  6.   <fineWinWidthStr>512</fineWinWidthStr>
  7.   <fineWinHeightStr>512</fineWinHeightStr>
  8.   <fineWinAccAzimuth>16</fineWinAccAzimuth>
  9.   <fineWinAccRange>16</fineWinAccRange>
  10.   <fineWinOversampling>128</fineWinOversampling>
  11.   <xCorrThreshold>0.1</xCorrThreshold>
  12.   <cohThreshold>0.15</cohThreshold>
  13.   <numBlocksPerOverlap>10</numBlocksPerOverlap>
  14.   <**useSuppliedRangeShift**>false</useSuppliedRangeShift>
  15.   <**useSuppliedAzimuthShift**>false</useSuppliedAzimuthShift>
  16.   <overallAzimuthShift>0.0</overallAzimuthShift>
  17.   <overallRangeShift>0.0</overallRangeShift>
  18. </parameters>

then the gpt in the script works. well, for me for now.

just saw the same answer by @ Abdel above. sigh, took me one afternoon to figure it out.

I believe these answers are already several times in the forum.

It is sometimes worth to use the search engine to get problems solve easily and avoid duplicated issues and questions.
Still, good that you managed to solve it

Hello, How could you solve the error ?, because I present the same error.
Thank you very much.

in snap2stamps folder/graph, find “coreg_ifg_computation_subset.xml” and replace "
useSuppliedRangeShift" line with two new lines with new names, as Abdel’s answer.

I understand, but I was referring to the error that MosiGitup pointed out, that is, an error like the following.
Error: [NodeId: StampsExport] The Product ‘_20171006_IW2’ already contains a band with the name ‘i_20171006.rslc’.

I am facing the same error. Did not find a solution yet. I am using snap2stamps scripts.

Thanks for your comments, mdelgado.

Well, it is not quite easy to find the exact question&answer given the length of each topic, maybe I missed something of how to use this forum effectively.

1 Like


Your error can be caused when the master image zip file is inside the slave folder. This creates one image pair with master-master interferogram, leading to the error you mentioned.
Please have a look here: Error: [NodeId: StampsExport] The Product ‘_20171006_IW2’ already contains a band with the name ‘i_20171006.rslc’

1 Like

Hi,how to run snap2stamps scripts such as “python project.conf” while slaves folder( contain zip files ) is outside the PROC folder?
my folder’s structure blow:
project folder: e:\proc
master: e:\proc\master\20190817_orb_spl.dim
snap2stamps: d:\software\snap2stamps-1.0.1\bin
slaves: e:\data\s1a\PSI\slaves
gpt: c:\Program Files\snap\bin\gpt.exe
soft enviroment: win10 snap7
Or it is recommanded to run snap2stamps scripts in ubuntu?

the only purpose of the project folder is to define where the slaves folder is located. Accordingly, you have to change the project folder in the conf file to

or move the slaves folder to

1 Like

ok ,thandk you .
the other question:in “python project.conf” ,I meet Fatal Error
[Fatal Error] :17517:15: XML document structures must start and end within the same entity.

but the final note is “Split slave [’/home/yzx/PSI/sn2st/slaves/20190618/’] successfully completed.”
I’m not comfirm the progress is right
I’ve repair coreg_ifg_computation.xml and coreg_ifg_computation_subset.xml as @szw mentioned.
soft enviroment:ubuntu18 snap7

If you are working with SNAP 7 indeed you still need to play with the xml for the coreg part.

However, you were splitting slaves so you should not touch xmls.
Probably you did and you forgot to close some xml tags, and the fatal error comes from there.

Be careful and pacient! Soon it will be snap2stamps for SNAP 7 and python 3

in the end ,coreg and other related folder is empty except split folder