Snaphu Unwrapping Plugin

I was referring to this line - what did you enter there?

Is snaphu already set in SNAP 8.0? And if yes is the procedure the same as for v7.x?

yes, it is implemented, but you will probably have to download the plugin and the bundle again and configure it

1 Like

@ABraun Thank you! I’ll try it.

SNAPHU unwrapping aborted. Screenshot as below. Processing graph and SNAPHU configuration file attached herein. Requesting support.

CSK_DEM-Generation-Pre-Processing-Snaphu.xml (5.7 KB)

snaphu.conf (1.7 KB)

have you seen this discussion? SNAPHU-Unwrapping

Also, I recommend increasing the pixel overlap SNAPHU parameters

also here: SNAPHU Unwrapping

In SNAP8.0.3 Snaphu_unwrapping is not opening. May i know the cause?
I installed this plugin.

Did you install both the bundle and the plugin as described in the tutorials?
In case you updated from SNAP 7 to version 8, you will have to reinstall the plugins as well.

Otherwise please specify your question.

I installed all plugins,

while opening the snaphu_unwrapping it is not opening but snaphu_export and import are opening.

if the window of snaphu is not even opening, there must be something wrong with the installation.
Have you followed all steps in the tutorial? There are some things to check under “Manage external tools” as well.

are all variables correctly configured?


Hi, I have tried to install snaphu on SNAP 8.0 version but when trying to enable snaphu phase Unwrapping, I get the following results.

Could you tell me in which step I am doing something wrong. Greetings

Hard to tell from the images, but they look alright. At least now the tool opens (above you reported that it did not open)
What happens when you select input data and an.output folder and run the tool?

Hello ABraun, Thanks for your reply.
I did the editing of the plugin and it already indicates that the status is active. Now I am going to see if the process can be carried out.

Dear Abraum: Upon invoking SNAP again and pretending to use the snaphu plugin, it turns out that it is inactive and I was unable to activate it again. I have followed the steps of your tutorial for January 2020. You will have another tutorial in which the procedure is specified a little more.
For your kind response and attention, receive a cordial greeting.

Ii recommend calling snaphu from the command line which is quite easy and less prone to errors.

Dear Abraun, Thank you for your response and guidance. I mention that I have performed the procedure by commands with version 1.4.2 as shown in the following images.

Where you open snaphu.conf in a text program; then in the Bin folder it is “pasted”, where there is an executable file and it runs under MSDOS. Obtaining the phase unwinding.
But now I want to do it in version 2.0.4, in which there is no executable file in the Bin folder.

Could you help me on how to perform the procedure in version 2.0.4 in the MAC terminal. Receives a warm greeting

I’m not experienced with Mac, sorry, But instead of copying the bin directory to where you need the snaphu executable it would be easier to add it to your system’s path so that you can call snaphu from any location without having to move it there.

Dear ABraun;
I installed plugin and bundle. the Snaphu unwrapping phase was run. I run it with overlap 0, 200 and 400 but the results were bad. Do you have any comment?