StaMPS-Visualizer, SNAP-StaMPS Workflow


#61

i have read the post in this title.two methods to solv this problem:
one is increase the radius to include all points and this will export the csv sucessfully(i dont not know why);
another is like @firat said ,use old version “staMPS_v3.3b1”
i hope some one can solve this bug


#62

Increasing the search radius is and was the solution since the problem occurred in the first place. Using stamps 3.x is not the solution since the problem occurred first in this version.

The bug, or whatever it can be called, is not yet clear. Sometimes when I have processed with stamps, I observed doubled coordinates, which should not occur as far as I understand the algorithms… Anyway, I have managed to get a MATLAB license and now I will search for an old Insar_master date folder and check some things, I will report my insights if I do have some :slight_smile:


#63

I have solved the problem by use stamps3.1 and repeat steps from 1 to 7,finally i export the csv file in the folder, and when i choose ts comparison two issus occurs in my picture:


(1)the line is not plot through the first time to the final time,but very random
(2)the time axix seems also random
i want wo know why?


#64

Could you provide the first 5 rows and maybe 6 columns (or more) of your exported csv table? Maybe a screenshot or an upload of this subset. My first guess is, that the csv was not created properly I could look it up and tell you what happened exactly.


#65

sorry , i foget to add some lines in mannual to my matlab,it has been solved


#66

how to subset
Error in as.data.frame.default(x[[i]], optional = TRUE) :
cannot coerce class ‘“function”’ to a data.frame


#67

There seems to be a mistake in line 23 (I know you copy pasted it from the manual of the application from github or the online example, I have fixed it there too)

use:

write.table(sub.csv, file = "/home/user/stamps_visualizer/stusi/newstudysite/20170310.csv",
            row.names = F, col.names = T, sep = ",")

Explanation: sub is not an object created by the script containing a data.frame but a function called sub (which is an object too). the function write.table() awaits a data.frame like object in x as input, this explains the error message. It maybe that I first worked with an object called sub, when I wrote the script but then changed sub to sub.csv, to avoid logical conflicts with the function sub…nice style be me but bad implemented by forgetting to rename all sub objects. Thanks for the report :slight_smile:


#68

Nevermind…Long story short:

In the new (4.x) Version of StamPS there were some changes in the ts plot which highly effects the variables used for the csv export. I changed the Matlab script in the Manual tab, now csv export is available for the new StamPS version! Look in the github repo for changes.

However, I was just able to test this with one example, it would be great if others can test the export code and report errors or problems, @ABraun, @firat @zhuhaxixiong maybe you could help me here with your processed results?

Details:

In StamPS 3.x a ts plot showed all ts (time series) for each MP (measurement point) within the search area, the data could be found in the object ts, in the newer version 4.x ts is a no longer a matrix with all results but a matrix with one row representing some mean of all selected MP, which becomes clear when looking at the ts plot, which is just a single ts averaged for all MP within the search radius. Therefore the ts plot becomes more less messy if many MP are selected…on the other hand details in single ts are lost…a good argument to use StamPS-Visualizer!
To overcome this problem the new object ph_mm containing all ts of all measurement points is subset, resulting in a object which is similar to the old ts object. Now the matrix can be made of all these objects as usual.

Thanks to @zhuhaxixiong and @firat for pointing in the direction of this change after the StaMPS 4. release!


#69

very interesting! However, I wasn’t able to correctly use StaMPS v4 by now, last time I tried it there were some error messages and I continued with version 3. But I’ll let you know once I switched - I will come to this, sooner or later.


#70

Did the error occur during regular stamps processing or the csv export? Both is interesting to me, if it was the first case, fell free to pm me maybe about it, if it is the latter, just tell me here and I look for a solution :slight_smile:


#71

regular StaMPS, at an early step if I recall it correctly. I used mt_prep_gamma_snap, as provided, but in one of the earlier stages. I’ll have to try again and let you know.


#72

with the help of so many masters in this part ,I finished my first PS graph,
this is my PS point in the area


so many points in the area and the TS comparison result is as follow

thank you all of you,and next i will try SBAS ,is there any special part in this forum


#73

good job!

export for SBAS is not yet supported in SNAP.


#74

thank you very much


#75

Please help me too to get PS.
I have created a co-registration stack of 32 images and prepared subset_master_deb_ifg_dinsar product. but the bands created like phase ,coherence are not opening in product view. showing this error.


#76

maybe the software problem


#77

ok thanks.
Is there any cloud service where i can Stamps process my data?


#78

i haven’t found the cloud service in the forum


#79

Hello @thho,

ı check it and ıt works fine on my vertical results, but ı saw something on staMPS-4.1 results which is different than stamsp3.1b. But this is not about stamps visulazier program. But ı think this is a important detail. Maybe you saw this too ? In stamps4.1 and in stamps3.3 ı did the same processing and in stamps 4.1 results, ı got so much more ps points according to stamps3.1. I don’t know why ?

And ı want to ask you a question. I saw that you used v-doa, not v-dos, you used a instead of s for atmospheric phase. I try to use a too but it didn’t work. I think, for using a, ı should install Train, right ? ı installed train inside the stamps4.1-beta but it didn’t work again. How should ı install Train for working a for substracting atmopsheric phase from velocities?

Thank you so much :slight_smile:


#80

Dear @firat,

good to hear that it works for you now! Concerning your other insights and questions (which are interesting) we should keep the forum as structured as possible and things already have become a bit messy in this topic due to the last posts concerning off topic questions. I think it is a good point in time to point this out and to suggest to open a new topic to ask about your questions. I would like to discuss some of them in more detail in an other topic :slight_smile: