Struggling to install snap

Hi All
I am struggling to install snap on my system.
I am using Ubuntu 18.04.1.
The process that I followed.

sudo apt install default-jre

Then I copied the the code on the download snap page and pasted in a note and made it exucutable.

When I run in terminal I get the following error:
gzip: sfx_archive.tar.gz: not in gzip format

I am sorry, but the installer file seems to be corrupted.
If you downloaded that file please try it again. If you
transfer that file with ftp please make sure that you are
using binary mode.

Please help

Either you are in the wrong forum or you have downloaded the wrong archive from the wrong location.
We don’t provide such an archive.
If you want to install ESA SNAP, the go to our download page.

Thank you for the reply.
Can you please then help me to install snap or were I ask for help. The download page does not show you how to install. I was on exactly that page you mentioned as said in my original question and copied that code to a file and made executable. I then tried to run it and got that error.

The page I used was exactly the one you mentioned in your reply. On that exact page I went to community and forum.

Actually, this should work straightforward. I just did it. This is the console log:

user@user:~/Downloads$ chmod u+x

user@user:~/Downloads$ ./

Unpacking JRE ...

Preparing JRE ...

Starting Installer ...

Here the installation ends succesfully.

user@user:~/Downloads$ cat /etc/*release*







One year ago someone had a similar problem. You could ask him if he solved it and how.

Thank you very much for your response.

I am very sorry if these questions seem very easy to you as I see in the similar question you also mentioned it is straightforward. I have followed exactly the same process you mentioned and got that error. However thank you very much. I will see what I can do to solve my problem. Sometimes for professionals, the process can seem straightforward.

Yes, I understand that for some people it can be challenging. But there are many people how were able to install SNAP without any problem. And it should actually work as I should in my last post.
If it is not working like, this something is special with your system.

Hi, marpet!

I am new to using Linux (Ubuntu 18.04.4 LTS). I am currently following some discussions here in the forum, and came across this post on how to install SNAP using the command line interface.

I followed the console log you’ve shared here, and I just want to ask if I successfully installed SNAP even though I got this Gtk Message as marked by the yellow box (left side of the screenshot).

If this means unsuccessful installation, how do I solve it?

If this means I successfully installed SNAP, I will be installing the StaMPS/MTI next. With regards to this, there are two source codes provided in github, Source code (zip) and Source code (tar.gz). Is it okay just to download the first source code (zip)?

Thank you in advance for you assistance.

I am following the by the way the documentation prepared by Dr. Matthias.

StaMPS/MTI is completely independent from SNAP. You can use StaMPS without having SNAP, for example when you prepare the interferograms with Gamma or other packages. But many people use SNAP for the preparation of the interferograms (and the StaMPS export offered by SNAP).
So, the second part of your question is probably not related to the first one.

Both StaMPS source codes contain the same packages, the just differ regarding the compression.
Regardless of SNAP, you have to compile and configure StaMPS separately (including triangle and snaphu as mentioned in the manual).

Thank you for your immediate response, ABraun.

Yup. My second question is not related to the first one. I am just taking it step-by-step as outlined by Dr. Matthias in his documentation (to avoid confusion). But did I install successfully SNAP? Because for interferogram preparation, I will be using SNAP since I do not have any other SAR software packages.

I am proceeding now with the StaMPS/MTI installation and following this discussion StaMPS 4.1 beta Installation in Ubuntu 18.04 where you are also of assistance to the one who posted the inquiry.

I hope to get good points from this froum to successfully install StaMPS/MTI. Using Linux is quiet challenging for me.

By the way, thank you again!

I cannot tell, so let’s wait for someone other to respond.

I think it wasn’t correctly installed. The installation process should have asked you some questions and I don’t see them.
I think the post below can help you:

Hi, marpet!

I will look into the thread you’ve shared. But installation of SNAP via the GUI is possible right? I think I’ve installed it via the GUI.

I was able to launch SNAP 6.0 as you can see from the screenshot. Then, it means it was installed successfully, isn’t?

Thank you.

Thank you, also @ABraun.

Yes, it was succssful. But why SNAP 6 and not SNAP 7?

I just changed to SNAP 7.

I somehow managed to install StaMPS-4.1-beta also, and now figuring out how to start processing Sentinel-1 interferometry.

Thank you.

Hi There,
I’m trying to install SNAP 8 in the virtual machine (I already have SNAP 7), but for some reason I got the following error message “gzip: sfx_archive.tar.gz: invalid compressed data–crc error”. I have download the installer several times, but the issue persist, could you please give some advice?

Cristian O.

On the download page are the MD5/SHA256 checksums provided.
Have you compared them with your downloaded file?
I provide an alternative location on my sharepoint.

Hola Marco,
Thanks a lot, I finally was able to install SNAP 8. I had to update my virtual machine to version 6.1.18, and then install a brand new Ubuntu operative system. Whit that SNAP installed smoothly. Thanks a lot for your help.
Kind regards
Cristian O.

1 Like